The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

"How do I change the maximum amount of memory RapidMiner Server is using"

User13User13 Member Posts: 155 Maven
edited May 2019 in Knowledge Base

Problem:

The maximum amount of memory RapidMiner Server uses is specified in a settings file and has to be changed by hand.

Solution:

To manually alter the maximum amount of memory an already installed RapidMiner Server uses, follow these steps:

On Windows:

  1. Open the bin/standalone.conf.bat file in your RapidMiner Server installation directory.

  2. Search for the line which contains the following fragment (number might differ) and replace the number with the amount of memory you want the server to use (in megabytes):


    -Xmx1024M
  3. Restart RapidMiner Server.

On Linux / Mac:

  1. Open the bin/standalone.conf file in your RapidMiner Server installation directory.

  2. Search for the line which contains the following fragment (number might differ) and replace the number with the amount of memory you want the server to use (in megabytes):


    -Xmx1024m
  3. Restart RapidMiner Server.



Tagged:

Comments

  • Options
    kaymankayman Member Posts: 662 Unicorn

    I believe this is a bit outdated, I also had to modify the max-memory.conf file in ./standalone/configuration before the actual values were changed.

Sign In or Register to comment.