"Java could not be launch" message when try to open Rapidminer

timematoomtimematoom Member Posts: 6 Contributor II
edited November 2018 in Help

2 weeks ago I still use Rapidminer fine, but now I get the message "Java could not be launched. Probably there is not enough memory space. Please close all other applications and try again" every time even though I have 14 GB free memory.

 

Here's the log I got when I run with .bat file. https://pastebin.com/TKKe6kv3

 

I use Rapidminer 64 bit, Windows 10 and 16GB of RAM.

Tagged:

Best Answer

  • timematoomtimematoom Posts: 6 Contributor II
    Solution Accepted

    It works now! It was because Rivatuner that come with MSI Afterburner somehow just start to interrupted without any reason. Thanks to Jonas (jwpfau) to point out in my inbox!

Answers

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761   Unicorn
  • timematoomtimematoom Member Posts: 6 Contributor II

    I'm using driver version 382.05 and there's nothing new yet... And I've also updated my Windows to the latest version. It's either Nvidia's driver or the latest Windows that make the program crash since it happened after these events.

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761   Unicorn

    Ugh, the older I get the more I despise Windows. Can you run a Linux VM and run the Linux version of RM?

  • jwpfaujwpfau Employee, Member Posts: 20   RM Engineering

    Do you run the latest version of RivaTuner Statistics Server (v7.0.0)?
    If you do and it's still broken, can you try to disable or remove it?


    If not, you can try to disable Direct3D support by editing the RapidMiner-Studio.bat

    rem ##################################
    rem ## ##
    rem ## Launching RapidMiner ##
    rem ## ##
    rem ##################################

    :launch
    echo Launching RapidMiner Studio GUI now...
    "%JAVA%" -Dsun.java2d.d3d=false %JVM_OPTIONS% -cp "%RAPIDMINER_HOME%"\lib\*;"%RAPIDMINER_HOME%"\lib\jdbc\* com.rapidminer.launcher.GUILauncher %CMD_LINE_ARGS%
    goto startEnd

     

     

  • korkmazakorkmaza Member Posts: 3 Contributor I

    I have this same problem. In the previous version, it was working just fine. 

    I checked if I have Rivatuner or MSI Afterburner, but I couldn't find them. Can you describe how you disable Rivatuner?

     

    I am running Windows 10 with 64 bit OS and 8 GB ram. 

     

    Thank you.

Sign In or Register to comment.