The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

RM Server putting all tables in the Postgres public schema

rachel_lomaskyrachel_lomasky Member Posts: 52 Guru
edited December 2018 in Help

I got RM talking to Postgres, but instead of putting its tables in the schema I indicated, they are all in the public schema.  Is there a way around this?

 

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE properties SYSTEM "http://java.sun.com/dtd/properties.dtd">
<properties>
<entry key="db_driver_path">data/jdbc/postgresql-9.3-1101-jdbc4.jar</entry>
<entry key="db_driver_path_is_relative">true</entry>
<entry key="db_driverclass">org.postgresql.Driver</entry>
<entry key="db_password">mypass</entry>
<entry key="db_port">5432</entry>
<entry key="db_schema">rapidminer</entry>
<entry key="db_system">PostgreSQL</entry>
<entry key="db_url">mymachine.cy5mwbb5zo5d.us-east-1.rds.amazonaws.com</entry>
<entry key="db_user">myuser</entry>
<entry key="server_service_id_overwrite">null</entry>
<entry key="eula_accepted">true</entry>
<entry key="server_port">8080</entry>
<entry key="mail_password"/>
<entry key="installation_directory">/opt/rapidminer</entry>
<entry key="license_key">mykey</entry>
<entry key="server_host">127.0.0.1</entry>
<entry key="server_register_as_service">false</entry>
<entry key="mail_port">25</entry>
<entry key="server_service_linux_variant">SUSE</entry>
<entry key="mail_sender"/>
<entry key="memory_max">2048</entry>
<entry key="radoop_proxy_port">1081</entry>
<entry key="mail_url"/>
<entry key="server_service_name">RapidMiner_Server_7_5_1</entry>
<entry key="java_home"/>
<entry key="server_service_id">RMS751SVC</entry>
<entry key="server_host_bind_only">false</entry>
<entry key="radoop_proxy_enable">false</entry>
<entry key="mail_user"/>
</properties>

 

Tagged:

Best Answer

  • Options
    rachel_lomaskyrachel_lomasky Member Posts: 52 Guru
    Solution Accepted

    The db_url is:

    <entry key="db_url">my_database.1.2.3.4/my_schema</entry>, where 1.2.3.4 is the IP of my database machine.

Answers

  • Options
    Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761 Unicorn

    @BalazsBarany any pointers for @rachel_lomasky?

  • Options
    BalazsBaranyBalazsBarany Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 955 Unicorn

    Just to clarify:

     

    Some other databases have a different meaning of schema than PostgreSQL.

     

    In PostgreSQL, there's a "database" that can contain schemas. The default schema is "public". You can create schemas with "CREATE SCHEMA myschema" and deselect the "use default schema" checkbox in RapidMiner to refer your schema. 

     

    This works well, I use RapidMiner heavily with PostgreSQL.

  • Options
    rachel_lomaskyrachel_lomasky Member Posts: 52 Guru

    That's for the RM configuration tables, not the data that I am working with?

Sign In or Register to comment.