Set Role

mbiclarmbiclar Member Posts: 6 Contributor I
edited December 2018 in Help

Hey Guys, I'm new to rapidminer!


So I am trying to set an 'ignore' role to a number of my columns in rapidminer. So I search the "Set Role" from the repository then I initially input the column that I want to change the role to 'ignore' then I clicked on the "Edit List" to add the other column, after I've done this and run the process it only applies to one of the columns that I have modified. Is there anything that I can do to address this problem?

Best Answer

  • Options
    jczogallajczogalla Employee, Member Posts: 144 RM Engineering
    Solution Accepted


    In RapidMiner, roles are unique. So in your scenario, you set one attribute after the other to that role, but in the end, only the last one retains the role.

    What exactly do you want to do? Maybe you can make better use of the "Select Attributes" operator, which lets you select the attributes you want to use from then on.


  • Options
    mbiclarmbiclar Member Posts: 6 Contributor I

    Thanks for the reply!


    So I have like 15 columns and I only want to make use of the 10 columns for making my decision tree as the other 5 are irrelevant.

  • Options
    mbiclarmbiclar Member Posts: 6 Contributor I

    And I also made use of the "Select Attributes" operator that you suggested and it worked!


    Thank you so much!


  • Options
    M_MartinM_Martin RapidMiner Certified Analyst, Member Posts: 125 Unicorn
    Hi @mbiclar: Here's another little trick that might come in handy: you can have any number of attributes in your data set that should not be considered by your model (i.e. not be considered a regular attribute).  For any attribute(s) that you would like to see for reference in your result set, but not be input to your model, use the Set Role operator and create a role that is the same name as the attribute that you want to see in your data set, but should ignored by your machine learning algorithm.
    You can use a single Set Role operator to define multiple role definitions at once - so if for some reason you want to see five attributes in your result set tat should not be considered by the algorithm(s) you are using, just create five different role names, each being the name of the attribute you want in your result set.  Each of these attributes will appear in a dark yellow background - which means these attributes are now special attributes, and not regular attributes. Special attributes are not considered when generating predictions.  Hope this helps and best wishes, Michael Martin
  • Options
    Telcontar120Telcontar120 Moderator, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,635 Unicorn
    To clarify, you are not allowed to have multiple attributes with the SAME special role, so if you take the approach described by @M_Martin (which I endorse) you must give each attribute its own unique role name.
    Brian T.
    Lindon Ventures 
    Data Science Consulting from Certified RapidMiner Experts
Sign In or Register to comment.