🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

Error Running Keras Extensions

M_MartinM_Martin RapidMiner Certified Analyst, Member Posts: 125   Unicorn
edited December 2018 in Help

Colleagues:

 

I installed the Keras Extensions (and required Python libraries) on a Dev box in my shop (through an environment crerated in Anaconds) following the very helpful instructions from Jesus - was even able to install Graphviz and Pydot.  As per the instructions, I tested the install within Preferences, and everything checked out great - no issues (see screeen shot "Keras_OK.png".

 

When I tried to run some of the sample Keas processes, I get a NullPointerException error message and the process aborts (see screen shot "Keras Issue.png").

 

I idid masnage to install the Keras extension on a different machine in my shop (also within an enviroment within Anaconda) - and am able to run the samples.  

 

Thanks for any guidance on troubleshooting the error message, and best wishes,

 

Michael

Tagged:

Best Answer

  • M_MartinM_Martin RapidMiner Certified Analyst, Member Posts: 125   Unicorn
    Solution Accepted

    Hi Colleagues:

     

    The Keras samples are now running after an uninstall and re-installation of Anaconda, Python 3.6.1, creating a new Python envinronment, and installing all of the required Python libraries.  

     

    In this case, I think the problem had to do with a combination of conflicting JAVA_HOME directories (due to a recent Java update) and conflicting values in the PATH environmental variables between user and system accounts. 

     

    Best wishes, Michael

    leti

Answers

  • M_MartinM_Martin RapidMiner Certified Analyst, Member Posts: 125   Unicorn

    Colleagues:  

     

    I have attached log messages re: the error referenced in my original post on this topic.  Any guidance / suggestions gratefully accepted!  

     

    Michael

  • LobbieLobbie Member Posts: 10 Contributor I

    Hi Michael,

     

    I am having the same problem as you did.  Can you please elaborate and possibly with screenshots on how to fix the JAVA Home and Path environment?

     

    Thanks,

    Lobbie

  • M_MartinM_Martin RapidMiner Certified Analyst, Member Posts: 125   Unicorn

    Hi Lobbie:

     

    I just saw your post  - In Windows, you open the Control Panel and then select the System Applet.  Within the System applet you select Advanced System Settings.  The dialog on the left will open, and by select "Environment Variables" the dialog on the right will open.  You use the second dialog to point to your JAVA_HOME directory.   Note that the JAVA_HOME settings can be different between the settings for a particular user, and the System setting - as in the case in the attached screenshot.  If you're the only person using your machine, you might as well have the same JAVA_HOME setting, unless this would break other applications that depend on a particular version of Java.

     

    Hope this helps, and best wishes, Michael

  • LobbieLobbie Member Posts: 10 Contributor I

    Hi Michael,

     

    I had to uninstall and reinstall Anaconda 3.6.2, install all the required libraries and set the JAVA_HOME like you did.  It is working now, thanks. 

     

    However, how do I point RapidMiner to the Python executable in the Python36 environment?  I couldn't so I install keras package into the python 'root' environment and it worked. 

     

    FYI, I can install graphviz through conda now.  Pydot is still out.

     

    Regards,

    Lobbie

  • M_MartinM_Martin RapidMiner Certified Analyst, Member Posts: 125   Unicorn

    Lobbie:

     

    1. Select "Settings" from the RapidMiner Studio main menu 

    2. Then select "Settings" from the drop down list of options, a dialog will open

    3. Point to the instance of Python.exe you want RapidMiner to use for Keras and Python scripting as shown in the attached screenshots.

     

    On my system, I pointed to Python.exe within the Anaconda environment mentioned in my instructions.

     

    Best wishes,   Michael

  • M_MartinM_Martin RapidMiner Certified Analyst, Member Posts: 125   Unicorn

    Hi Lobbie:

     

    If you do a search for 

     

    "Keras Deep Learning extension"

     

    on the RapidMiner support form, you'll see a listing for a knowledge base post started by Jesus Puente about the Keras entension.  Click on that thread and you'll come across many good posts in that subject. 

     

    Near the botttom of the series of posts in that thread is a longer post I wrote that details how I was able to set up Keras on multiple machines in my company.  

     

    Best wishes, Michael

     

    sgenzeryasunotkt
  • yasunotktyasunotkt Member Posts: 7 Contributor I

    Hi !

    I try to use Keras, but error message "Excution of Python script failed" as follows print screen.

    I finished to install the Tensorflow and Keras on Windows. 

    But I have not already set the path, then please advice me the path setting.  

     

    Install TensorFlow & Keras.png

     

  • yasunotktyasunotkt Member Posts: 7 Contributor I

    I understand "the preferences at the setting menu".

    I tested and get a message "Graphviz, Pydot is not installed".

    I solved my error.

    Thanks for this subject contributers !

    sgenzer
  • yasunotktyasunotkt Member Posts: 7 Contributor I

    Hi Coleague :

     

    I try to model the three classification problem whose label are "a,b,c", and it stands for bridges deterioration level in oder to enable the predictive maintenance. The deterioration includes the steal corrosion and the crack of ferro-concrete. Exactly I prepare the datasets along twenty years whose number of examples are four thousands.

    I build the prototype using Keras extension : Convolutional Neural Nets ELU-base with twelve layers.

    Then I tried to run the model, but error message is repeated. 

    How do I view Python script; line 285 ?

    How well use the parameters at Convolutional layer ? 

    What means the message "ndim=2 or 3",  "conv1d_1" ?   

    Of cource, I studied how to set the key parameters such as the number of height, width of input / output, convolution-filter, stride, padding, pool size.

    I want advisary suggestion. 

    スライド1.JPGスライド2.JPG

  • yasunotktyasunotkt Member Posts: 7 Contributor I

    I also upload the rmp file and the dataset of steal corrosion at bridges.

  • pschlunderpschlunder Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, RMResearcher, Member Posts: 96  RM Research

    Hi yasunotkt,

     

    please check the input_shape parameter of the Keras Model Operator. When using a Conv. layer you need to provide two values (depending on the use case). In your scenario you might want to provide the number of examples and attributes after the Split Data so: (3851, 48). Maybe the part about the input shape in the Keras documentation might be helpful, you find it here.

     

    P.S.: you might need to reduce the dilation rate in order for the process to work.

     

    Hope this solves it.

     

    Regards,

    Philipp

    sgenzer
  • tilizatiliza Member, University Professor Posts: 1  University Professor

    Hi,

    I am new in rapidminer and trying to use keras model. Can anyone help me how do I solve this issue? I have installed python 3.5.2 and set the path for both python and keras. Thank you in advance.

     

    kerasmodelerror.png

     

Sign In or Register to comment.