🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

How to correctly optimize Macros in Rapidminer

nourhan_tayanourhan_taya Member Posts: 11 Contributor I
edited December 2018 in Help

Hi,

i am using artificial neural networks for financial markets prediction. When i used " set macro" operator to optimize the number of hidden neurons, the program give me an error messsage. I did not understand this message error and i do not know how to solve the problem.

Thanks in advance

1.png2.png

Tagged:

Best Answer

  • FBTFBT Member Posts: 106   Unicorn
    Solution Accepted

    This is most likely caused by a wrong process order. You are requesting the macro value before it was generated. To change the process order of individual operators, click on the blue rectangle on the top right corner of the process pane (see picture below).

     

    Process_order.png 

    nourhan_taya

Answers

  • FBTFBT Member Posts: 106   Unicorn

    The problem is most likely caused by the fact that macros have the data type "string" and your process expects a numeric value. Please take a look at this post. It should help you to resolve the issue. 

    nourhan_taya
  • nourhan_tayanourhan_taya Member Posts: 11 Contributor I

    Many thanks for reply

    i have tried extract macro for solving the problem but undefined macro message appears. i suspected that there is a problem in the procedure but i couldnot recognize it1.png2.png3.png

  • nourhan_tayanourhan_taya Member Posts: 11 Contributor I

    Many thanks. this solution solved my problem

    sgenzer
  • nourhan_tayanourhan_taya Member Posts: 11 Contributor I

    hi,

    the previous solution solved the problem but i did not work for deep learning operator

    p1.pngp2.pngp3.pngp4.png

  • FBTFBT Member Posts: 106   Unicorn

    Have you tried running it like this? The warning you are seeing is caused by the process' meta data not being in sync with its real data. This is not uncommon when using macros and usually is only a warning, not an error. From your pictures, I believe you should be able to run it successfully like it is. In case it does not work, maybe you can post your process XML and I will take a look. For this you just need to copy the XML that you can find in your XML panel and copy it into this thread within the "Insert Code" tags (</>).

    sgenzer
Sign In or Register to comment.