basic Process

mhkhourymhkhoury Member Posts: 2 Contributor I
edited December 2018 in Help

Ok , I am newbie to this Rapid Miner thing. I am trying to do a simple process as follows :

 

1 - Select a query (Count Query)

2 - IF the count is > 1 then send an email

 

simple . I have been battling with this for ages.

 

Here is my process . Can someone help me please

Tagged:

Answers

  • sgenzersgenzer 12Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,266  Community Manager

    hello @mhkhoury - no problem.  So I think your struggle is the Branch expression.  It should be:

     

    if(TotalUnSentCount==0,TRUE,FALSE)

     

    Scott

     

  • mhkhourymhkhoury Member Posts: 2 Contributor I

    I placed the suggested expression with no luck it says it cannot parse the expression the variable TotalUnsentCount is unknown !!! how come ?

  • Edin_KlapicEdin_Klapic Moderator, Employee, RMResearcher, Member Posts: 247  RM Data Scientist

    Hi @mhkhoury,

     

    I have some remarks here:

    1. You used parenthesis within PrintToConsole ==> %(TotalUnSentCount).
      In RapidMiner Macros are used with curly brackets ==> %{TotalUnSentCount}
    2. Branch - Condition type: expression
      Here you (usually) compare to values and not check for the value of an Attribute.
      If you want to use this I suggest to extract the value of the Attribute TotalUnSentCount as Macro (Extract Macro).
      Set the macro type to data_value, attribute name is TotalUnSentCount, and example index is 1. macro is the name of the new macro.
      Then the expression would be %{name_of_the_macro}=="test_value" (%{TotalUnSentCount}=="0"). Since Macros are by default strings you need to double quote the right side of the expression.
    3. Branch - Condition type: attribute_value_filter
      Since you have just one example, you could also use this condition type. The usage would be TotalUnSentCount = 0.

    I was not able to import the XML you attached - I took me some time to fix the problem. 

    So for future usage please do one of the following:

    Within RapidMiner there is an XML panel under View. Please copy the content into the post (using the code insert tool </>) or attach your process file (file extension rmp).

     

    Hope this helps :)

     

    Best,

    Edin

    sgenzer
Sign In or Register to comment.