BUG: Enrich Data by Webservice - Web Mining : Does not pass 'request properties'

kludikovskykludikovsky Member Posts: 30  Guru
edited December 2018 in Help

I am trying to access the MailChimp "Enrich Data by Webservice". 
After reading tons of Documentation I tried to check what is actually sent to compare it to a working Chrome REST extension test.
There it shows that the request properties are not sent to the server. Therefore no authentican can work, nor any other instructions.

This will also explain most of the similar discussions here in the forum.
This is the process: (Copies and pasted from the canvas) 

<?xml version="1.0" encoding="UTF-8"?><process version="7.6.001">
<operator activated="true" class="operator_toolbox:create_exampleset_from_doc" compatibility="0.5.000" expanded="true" height="68" name="Create ExampleSet" width="90" x="45" y="136">
<parameter key="Column Separator" value=","/>
<parameter key="Input Csv" value="function&#10;lists"/>
</operator>
</process>
<?xml version="1.0" encoding="UTF-8"?><process version="7.6.001">
<operator activated="true" class="web:enrich_data_by_webservice" compatibility="7.3.000" expanded="true" height="68" name="Enrich Data by Webservice (2)" width="90" x="246" y="136">
<parameter key="query_type" value="Regular Expression"/>
<list key="string_machting_queries"/>
<parameter key="attribute_type" value="Nominal"/>
<list key="regular_expression_queries">
<parameter key="output" value=".*"/>
</list>
<list key="regular_region_queries"/>
<list key="xpath_queries"/>
<list key="namespaces"/>
<parameter key="ignore_CDATA" value="true"/>
<parameter key="assume_html" value="true"/>
<list key="index_queries">
<parameter key="function" value="1.1"/>
</list>
<list key="jsonpath_queries"/>
<parameter key="request_method" value="GET"/>
<parameter key="url" value="http://us16.api.mailchimp.com/3.0/lists/"/>
<parameter key="separator" value=";"/>
<parameter key="delay" value="0"/>
<list key="request_properties">
<parameter key="authorization:" value="Bearer a2xsO.....................................zMTY="/>
<parameter key="xyz:" value="abc"/>
</list>
<parameter key="encoding" value="UTF-8"/>
</operator>
</process>


Neither the 'authorization' nor the 'xyz' are in the request as can be seen in the Wireshark trace:

Hypertext Transfer Protocol
GET /3.0/lists/ HTTP/1.1\r\n
[Expert Info (Chat/Sequence): GET /3.0/lists/ HTTP/1.1\r\n]
[GET /3.0/lists/ HTTP/1.1\r\n]
[Severity level: Chat]
[Group: Sequence]
Request Method: GET
Request URI: /3.0/lists/
Request Version: HTTP/1.1
User-Agent: Java/1.8.0_141\r\n
Host: us16.api.mailchimp.com\r\n
Accept: text/html, image/gif, image/jpeg, *; q=.2, */*; q=.2\r\n
Connection: keep-alive\r\n
\r\n
[Full request URI: http://us16.api.mailchimp.com/3.0/lists/]
[HTTP request 1/1]
[Response in frame: 1989]


I am currently using RM 7.6.001

 

Answers

  • Telcontar120Telcontar120 Moderator, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,210   Unicorn

    This XML appears malformed and doesn't render---can you try reposting the XML using these instructions: 

    Start by copying the full XML from the "XML" tab in RapidMiner into your post using the </> code insert tool. Need help? Read this KB article to learn more.  Do NOT just copy and paste the operators from the Process canvas!

    Then others will actually able to look at your process and offer comments.  

     

    Brian T.
    Lindon Ventures 
    Data Science Consulting from Certified RapidMiner Experts
  • sgenzersgenzer 12Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,383  Community Manager

    it's been sorted out @Telcontar120 - there are four duplicates of this post.  Thx.


    Scott

     

     

  • kludikovskykludikovsky Member Posts: 30  Guru

    @Telcontar120 here it is.

     

    but you can also take the above and copy and paste it into the canvas. Should work as well.

     

Sign In or Register to comment.