NullPointerException with AttributeConstructionsLoader

RasputinRasputin Member Posts: 16  Maven
edited November 2018 in Help
Hello,

I am using a genetic algorithm (in this case the AGA) to generate new features, which are written to a file by the AttributeConstructionsWriter operator. Then, in another project, I load the very same data as in the first project and try to reconstruct the attributes via AttributeConstructionsLoader, but that operator produces a NullPointerException:

NullPointerException
process failed
Message: null

This is the construction file I try to read:
<?xml version="1.0" encoding="US-ASCII"?>
<constructions version="4.4">
    <attribute name="Hillas_Dist0" construction="Hillas_Dist0"/>
    <attribute name="Hillas_Area" construction="Hillas_Area"/>
    <attribute name="Hillas_CosDelta" construction="Hillas_CosDelta"/>
    <attribute name="HillasExt_M3Trans" construction="HillasExt_M3Trans"/>
    <attribute name="ImagePar_NumSatPixelsHG" construction="ImagePar_NumSatPixelsHG"/>
    <attribute name="gensym13" construction="(Hillas_BorderLine * ImagePar_NumSinglePixels)"/>
    <attribute name="Hillas_Length" construction="Hillas_Length"/>
    <attribute name="Hillas_Size" construction="Hillas_Size"/>
    <attribute name="Hillas_MeanX" construction="Hillas_MeanX"/>
    <attribute name="Hillas_BorderLine" construction="Hillas_BorderLine"/>
    <attribute name="ImagePar_SizeMainIsland" construction="ImagePar_SizeMainIsland"/>
    <attribute name="HillasExt_M3Long" construction="HillasExt_M3Long"/>
    <attribute name="ImageParNew_ConcCore" construction="ImageParNew_ConcCore"/>
    <attribute name="gensym95" construction="(ImageParNew_ConcCore + 1/(ImageParNew_NumCorePixels))"/>
    <attribute name="gensym96" construction="(ImagePar_SizeSinglePixels + 1/(ImageParNew_NumCorePixels))"/>
    <attribute name="gensym97" construction="((ImagePar_SizeSinglePixels + 1/(ImageParNew_NumCorePixels)) / (Hillas_BorderLine * ImagePar_NumSinglePixels))"/>
    <attribute name="gensym104" construction="(ImagePar_NumSatPixelsHG + HillasExt_M3Long)"/>
    <attribute name="gensym105" construction="((ImagePar_SizeSinglePixels + 1/(ImageParNew_NumCorePixels)) pow Hillas_BorderLine)"/>
    <attribute name="gensym113" construction="(ImagePar_SizeSinglePixels * Hillas_Length)"/>
    <attribute name="gensym114" construction="(((ImagePar_SizeSinglePixels + 1/(ImageParNew_NumCorePixels)) pow Hillas_BorderLine) pow Hillas_Width)"/>
    <attribute name="gensym116" construction="(ImagePar_SizeSubIslands * (ImagePar_SizeSinglePixels + 1/(ImageParNew_NumCorePixels)))"/>
    <attribute name="gensym117" construction="((ImageParNew_ConcCore + 1/(ImageParNew_NumCorePixels)) / ((ImagePar_SizeSinglePixels + 1/(ImageParNew_NumCorePixels)) pow Hillas_BorderLine))"/>
    <attribute name="gensym118" construction="(1/(ImageParNew_NumCorePixels) * (ImageParNew_ConcCore + 1/(ImageParNew_NumCorePixels)))"/>
</constructions>
All attributes used in the formulas are present in the example set. Is there something wrong with this file?

I am using RapidMiner 4.4 with java-1.6 on Linux.

Answers

  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,525   Unicorn
    Hi,
    that was a bug occuring with these more complex braced expressions. Unfortunately there is no easy way arround, but you might copy the expressions manually into a feature construction operator, if you have to do this just once.
    It is somehow ill timed, because we have just published the 4.5 release, so the next release will take some time. In theory, you could download the newest CVS version, but we have some problems with synchronizing our local repository with the public one on source forge. Our Admins struggling with that and we hope to solve this problem in the next days. If you want, I can write you, as soon as the bugfixed version is available.

    Greetings,
      Sebastian
  • RasputinRasputin Member Posts: 16  Maven
    Hi,

    thanks for your reply. It would be nice if you could write me. Copying the expression by hand is not an option, because for my assignment I run a batch of Genetic Feature Generators and want to test the generated features in other projects, so I would have to do that much more than once.
    Is this bug currently being worked on? I really need this feature for my assignment...

    -Rasputin
  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,525   Unicorn
    Hi,
    the bug is already solved, but delivering the new program is a little bit difficult. I hope we get the cvs mirroring to work again until the end of this week, so that you can download the current developer version from cvs. But I can't guarantee anything...

    Greetings,
      Sebastian
  • RasputinRasputin Member Posts: 16  Maven
    Could you please send me a snapshot or upload it somewhere? Actually, I had planned to finish my work by the end of next week, and this bug prevents me from doing a very central analysis.

    Greetins,
    Marius
Sign In or Register to comment.