Options

server error 500 occurred

micheljanosmicheljanos Member Posts: 40 Maven
edited December 2018 in Help

Hello, 

 

At browsing sever command I get the message "Error occurred A server error 500 occurred: . The error has been recorded. " 

 

 

 Best,

 

Michel

Tagged:

Answers

  • Options
    MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,520 RM Data Scientist

    Hi @micheljanos,

     

    can you please have a look on the server.log? There should be more information. See: https://docs.rapidminer.com/latest/server/administration/error-logs.html

     

    Best,

    Martin

    - Sr. Director Data Solutions, Altair RapidMiner -
    Dortmund, Germany
  • Options
    Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761 Unicorn

    It's been my experience with this error that there is a connectivity problem. 

  • Options
    zprekopcsakzprekopcsak RapidMiner Certified Expert, Member Posts: 47 Guru

    @micheljanos: which version of Server are you using?

  • Options
    micheljanosmicheljanos Member Posts: 40 Maven

    Hi Zoltan,

     

    Please check the steps I took today:

     

    1. Started RM v. 7.6.001 and unsucesfully tried to connect to server. I was normally connecting, but have not used the Server for a few weeks.

    2. I re-installed mySql and RM server (V.8) and was able to connect to App Designer front page but not to Web interface getting the 500 error.

    3. I made and update to RM v.8, by Marketplace.

    4. After re-starting RM the update is not installed and I can't even connect to Server.

    See att. Server log

     

    best,

     

    Michel

  • Options
    Nils_WoehlerNils_Woehler Member Posts: 463 Maven

    @micheljanos it seems that one of the components of RM Server could not start due to an illegal host name:

     

    Caused by: java.lang.IllegalStateException: java.net.URISyntaxException: Illegal character in hostname at index 10: tcp://NASA_SERVER:5672

    Please open $RM_SERVER_INSTALLATION$/standalone/configuration/execution.properties and change the property `jobservice.queue.activemq.host` to an IP or a valid hostname according to https://www.ietf.org/rfc/rfc2396.txt

    Afterwards please restart RapidMiner Server and check whether it is working now.

  • Options
    micheljanosmicheljanos Member Posts: 40 Maven

    Capturar.JPG



    How do I change execution.properties?




    @Nils_Woehler wrote:

    @micheljanos it seems that one of the components of RM Server could not start due to an illegal host name:

     

    Caused by: java.lang.IllegalStateException: java.net.URISyntaxException: Illegal character in hostname at index 10: tcp://NASA_SERVER:5672

    Please open $RM_SERVER_INSTALLATION$/standalone/configuration/execution.properties and change the property `jobservice.queue.activemq.host` to an IP or a valid hostname according to https://www.ietf.org/rfc/rfc2396.txt

    Afterwards please restart RapidMiner Server and check whether it is working now.


     

  • Options
    atimmatimm Employee, Member Posts: 24 RM Engineering

    @micheljanos You can open the file execution.properties with your favorite text editor.

  • Options
    micheljanosmicheljanos Member Posts: 40 Maven

    After changes still 500 error

    Capturar1.JPGCapturar2.JPG

  • Options
    atimmatimm Employee, Member Posts: 24 RM Engineering

    @micheljanos

     

    I would recommend to re-install RapidMiner Server and use your correct hostname or simply localhost to make it work properly.

    Hope that helps, we will get your server up and running!

Sign In or Register to comment.