Return back the setting to keep disabled operators connected

yzanyzan Member Posts: 66 Unicorn
edited December 2018 in Product Feedback - Resolved

In older versions of RapidMiner Studio (e.g. in the 7.x line), there was a setting: User Interface > Process editor > Disconnect operators when disabled. But this setting was removed in 8.x line (it was changed to "Bridge connection if operator is removed", which does not allow me to retain the connections).

 

Reasoning:

It simply takes some mental effort to correctly recreate the disappeared connections. Do not make me think.

kypexingmeierPanj1jorge_carballo
4
4 votes

Fixed and Released · Last Updated

9.1.0

Comments

  • sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager
  • kypexinkypexin Moderator, RapidMiner Certified Analyst, Member Posts: 291 Unicorn

    Hi @yzan

     

    I didn't even know there was such a setting!! But I ABSOLUTELY agree that this is a feature I personally am lacking for years. If you disable operator, it is much better to make all connections go thru but not to disconnect that operator completely. I would say this is something which I struggle with in 99% of all my processes ever. 

  • Panj1Panj1 Member Posts: 2 Contributor I

     Upvoted.

     

    The new behavior pisses me off. 

  • Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,985 RM Engineering
    Studio 9.1 introduced the following settings:
    • Connections of a disabled operator should be: [removed, bridged, kept]
    • Connections of a removed operator should be: [removed, bridged]
    Default is highlighted.
Sign In or Register to comment.