image

🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

SSL Connection to MySQL in Studio and on Server

eric_duelleric_duell Member Posts: 2 Contributor I
edited November 2019 in Help

Hello, can someone please point me to the documentation needed to set up Studio and Server connections to a MySQL server when SSL encryption is required?

 

Thank you,

Eric

Best Answer

  • Edin_KlapicEdin_Klapic Moderator, Employee, RMResearcher, Member Posts: 294  RM Data Scientist
    Solution Accepted

    Hi @eric_duell,

     

    Welcome to the RapidMiner Community!

     

    Unfortunately, there are multiple steps necessary to achieve this.

    1. Force MySQL Server to use SSL connections (Some documentation can be found here: https://dev.mysql.com/doc/connector-j/5.1/en/connector-j-reference-using-ssl.html.) You also need to get a SSL certificate.
    2. Configure the Database connection details from within RapidMiner accordingly
      At "Database scheme" enter: <your_schema_name>?useSSL=true&ssl=required
    3. Configure the Database connection details in the RapidMiner Server Webinterface accordingly
      At "Schema" enter: <your_schema_name>?useSSL=true&ssl=required

    This should do the trick.

     

    Happy mining,

    Edin

     

    By the way:

    The following error message in the server.log of RapidMiner Server can most often be ignored. In most installations the database is installed on localhost where the usual MySQL Standard port 3306 is blocked for inbound connections.

     

    ERROR [stderr] (JCA PoolFiller) Tue Mar 20 13:00:19 CET 2018 WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.

Answers

  • eric_duelleric_duell Member Posts: 2 Contributor I

    This is perfect - exactly what I needed. Thank you!

    sgenzer
Sign In or Register to comment.