Options

how to verify a data model that we created in rapidminer.......

satyendrasatyendra Member Posts: 13 Contributor II
edited November 2018 in Help
hiiii all,
          i am working on breast cancer data (the dataset contains around 650 entries) to find out the patterns in it using rapidminer. in this database we several field ,and i have to predict whether the breast cancer is benign or malignant (2 for benign and 4 for representing malignant is used)............................ :-[. i have created a data model using rapid and got the following result.................

                        true 2                          true4                          class precision

pred 2              433                                  9                                  97.96%
pred 4              11                                  230                                95.44%

class recall    97.52%                          96.23%

  now i want to verify this data model using new data ....................so how to verify this ???????....................please help me ..



Answers

  • Options
    landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Hi,
    this is exactly what was rapidminer made for. So it's quite easy:
    1. Load the data
    2. Load the model
    3. Apply the model using "ModelApplier"
    4. Calculate performance using "ClassificationPerformance".

    Of course, your new data has to contain the real label...

    Greetings,
      Sebastian
  • Options
    satyendrasatyendra Member Posts: 13 Contributor II
    sir ............thanks for the reply................here we are facing one more  problem that is .................when we are loading model using.......... model loader..........it is asking for a model file(*.mod) but when we are saving the data model  ...........the default format it is showing is ( .xml ) .................even we are changing the format and saving it in the (.mod )format.................but when we are running the application it is showing the        " wrong format " as an error.....................so please help us in order to sort out this problem?????
  • Options
    landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Hi,
    is your point key stuck?

    Use the ModelLoader with the XMLZipped as output type. Then use the ModelLoader for loading again. This should work...

    Greetings,
      Sebastian
Sign In or Register to comment.