Linear Discriminant Analysis with polynomial label

s96142s96142 Member Posts: 4 Contributor I
edited November 2018 in Help

Does "Linear Discriminant Analysis" can process "polynomial" label?

The "F1" help information of the operator show "support polynomial label"

 

but with polynomial label dataset as input,run process will show error

 

I use the lasted V8.2 versionI, and I see some v6.xx version sample video can process 

 

this is the v8.2 probem?

 

 

 

 

 

 

Best Answers

  • lionelderkrikorlionelderkrikor Posts: 731   Unicorn
    Solution Accepted

    Hi again @s96142,

     

    You made a mistake in the parameters of the Filter Examples operator. Here the right filters : 

    LDA.png

     

    and the corrected process : 

    <?xml version="1.0" encoding="UTF-8"?><process version="9.0.000-BETA">
    <context>
    <input/>
    <output/>
    <macros/>
    </context>
    <operator activated="true" class="process" compatibility="9.0.000-BETA" expanded="true" name="Process">
    <process expanded="true">
    <operator activated="true" class="read_csv" compatibility="9.0.000-BETA" expanded="true" height="68" name="Read CSV" width="90" x="45" y="85">
    <parameter key="csv_file" value="C:\Users\Lionel\Downloads\Chapter07DataSet_Training.csv"/>
    <parameter key="column_separators" value=","/>
    <parameter key="skip_comments" value="true"/>
    <parameter key="date_format" value="MMM d, yyyy h:mm:ss a z"/>
    <list key="annotations"/>
    <parameter key="encoding" value="windows-1252"/>
    <list key="data_set_meta_data_information">
    <parameter key="0" value="Age.true.real.attribute"/>
    <parameter key="1" value="Strength.true.integer.attribute"/>
    <parameter key="2" value="Quickness.true.integer.attribute"/>
    <parameter key="3" value="Injury.true.integer.attribute"/>
    <parameter key="4" value="Vision.true.integer.attribute"/>
    <parameter key="5" value="Endurance.true.integer.attribute"/>
    <parameter key="6" value="Agility.true.integer.attribute"/>
    <parameter key="7" value="Decision_Making.true.integer.attribute"/>
    <parameter key="8" value="Prime_Sport.true.nominal.label"/>
    </list>
    <parameter key="read_not_matching_values_as_missings" value="false"/>
    </operator>
    <operator activated="true" class="filter_examples" compatibility="9.0.000-BETA" expanded="true" height="103" name="Filter Examples" width="90" x="313" y="85">
    <list key="filters_list">
    <parameter key="filters_entry_key" value="Decision_Making.ge.3"/>
    <parameter key="filters_entry_key" value="Decision_Making.le.100"/>
    </list>
    </operator>
    <operator activated="true" class="set_role" compatibility="9.0.000-BETA" expanded="true" height="82" name="Set Role" width="90" x="581" y="85">
    <parameter key="attribute_name" value="Prime_Sport"/>
    <parameter key="target_role" value="label"/>
    <list key="set_additional_roles"/>
    </operator>
    <operator activated="true" class="linear_discriminant_analysis" compatibility="9.0.000-BETA" expanded="true" height="82" name="LDA" width="90" x="715" y="85"/>
    <connect from_op="Read CSV" from_port="output" to_op="Filter Examples" to_port="example set input"/>
    <connect from_op="Filter Examples" from_port="example set output" to_op="Set Role" to_port="example set input"/>
    <connect from_op="Set Role" from_port="example set output" to_op="LDA" to_port="training set"/>
    <connect from_op="LDA" from_port="model" to_port="result 1"/>
    <connect from_op="LDA" from_port="exampleSet" to_port="result 2"/>
    <portSpacing port="source_input 1" spacing="0"/>
    <portSpacing port="sink_result 1" spacing="0"/>
    <portSpacing port="sink_result 2" spacing="0"/>
    <portSpacing port="sink_result 3" spacing="0"/>
    </process>
    </operator>
    </process>

    Regards,

     

    Lionel

     

  • s96142s96142 Posts: 4 Contributor I
    Solution Accepted

    After fixing it, the process can run without problem.

    Thank you! 

Answers

  • lionelderkrikorlionelderkrikor Moderator, RapidMiner Certified Analyst, Member Posts: 731   Unicorn

    Hi @s96142,

     

    I ran some of my processes with LDA and polynominal label using RapidMiner 8.2 and RapidMiner 9.0 : 

    RapidMiner don't raise an error....

    So are you sure to have effectively set your label as "polynominal" ? (maybe your label is initialy "numerical"....)

     

    Can you share your process and your dataset(s) in order we can reproduce what you observe ?

     

    Regards,

     

    Lionel

     

  • s96142s96142 Member Posts: 4 Contributor I

    I practice the sample in "Data Mining for The masses" which download from your website(page 124/264).

    Below is error message:

    AA.jpg

  • s96142s96142 Member Posts: 4 Contributor I

    This is my process and dataset.

     

Sign In or Register to comment.