Importing dates automatically with standard european time format?

felix_wfelix_w Member Posts: 61 Contributor II
edited December 2018 in Help

Dear Rapidminer Community, 


I have got this format: "01.01.2017" in a table.

As soons as I import it into Rapidminer I get this: "Jan 1, 2017 12:00:00 AM CET"


Is it possible to switch Rapidminer to automatically use middle european time format and not convert all the dates into UK/US format? I looked at "Settings --> Preferences" in Rapidminer but couldn't find any option which would have worked?


Best regards



Best Answer

  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager
    Solution Accepted

    yes exactly as @BalazsBarany explained and I can confirm that you cannot change the way dates/times are displayed in RapidMiner. If they specifically want to display them in a different format, most users copy the attribute and use Date to Nominal.




  • Options
    BalazsBaranyBalazsBarany Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 955 Unicorn



    it's necessary to distinguish between the display format and the import format.


    The "Jan 1, 2017" is how RapidMiner displays dates and times. I don't know of a configuration setting for this. But if you see the correct attribute types Date and Date time in the Statistics in the Result View, then you know that the attribute is interpreted as date or date/time. 


    If you get dates or timestamps from a database or a file format where they are marked as such, you'll get correct dates. Sometimes you need to enter the correct time zone.


    Importing from CSV and other formats works by specifying the correct date format in the Java SimpleDateFormat system.


    Lastly, if you have dates or times and you'd like to have them in a specified format, you can use Date to Nominal to format them. They will be converted to nominal after applying this operator.




  • Options
    felix_wfelix_w Member Posts: 61 Contributor II

    Thank you Balázs and Scott for your replies!

Sign In or Register to comment.