The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

I am getting the below error on linux console when I am trying to install rapidminer server .

khadevishal18khadevishal18 Member Posts: 6 Newbie
edited December 2018 in Help
 ERROR [org.apache.coyote.http11.Http11Protocol] (MSC service thread 1-2) JBWEB003043: Error initializing endpoint: java.net.BindException: Address already in use (Bind failed) /0.0.0.0:8080
        at org.apache.tomcat.util.net.JIoEndpoint.init(JIoEndpoint.java:979) [jbossweb-7.5.3.Final.jar:7.5.3.Final]
        at org.apache.coyote.http11.Http11Protocol.init(Http11Protocol.java:174) [jbossweb-7.5.3.Final.jar:7.5.3.Final]
        at org.apache.catalina.connector.Connector.init(Connector.java:986) [jbossweb-7.5.3.Final.jar:7.5.3.Final]
        at org.jboss.as.web.WebConnectorService.start(WebConnectorService.java:318) [jboss-as-web-7.5.0.Final-redhat-15.jar:7.5.0.Final-redhat-15]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1980) [jboss-msc-1.1.5.Final-redhat-1.jar:1.1.5.Final-redhat-1]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1913) [jboss-msc-1.1.5.Final-redhat-1.jar:1.1.5.Final-redhat-1]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [rt.jar:1.8.0_181]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [rt.jar:1.8.0_181]
        at java.lang.Thread.run(Unknown Source) [rt.jar:1.8.0_181]

Answers

  • Options
    jczogallajczogalla Employee, Member Posts: 144 RM Engineering
    Hi @khadevishal18!
    It seems you already ahve some server/application runnign that uses the 8080 port of your computer.
    You can see here how to install the server in headless mode, and it is also mentioned there that you can provide the xml file for the configuration. You can change the port for the web interface there.

    I hope this helps! Cheers
    Jan
  • Options
    khadevishal18khadevishal18 Member Posts: 6 Newbie
    In which configuration file the changes has to be made (only RMS_Installer.xml or any other configuration files) ?
  • Options
    jczogallajczogalla Employee, Member Posts: 144 RM Engineering
    If i understand the documentation page correctly, you only have to adapt the RMS_Installer.xml. Maybe @Nils_Woehler or @jpuente know more?
  • Options
    rfuentealbarfuentealba Moderator, RapidMiner Certified Analyst, Member, University Professor Posts: 568 Unicorn
    Duh, I had a terrific answer but it got wiped by my browser! Or vanilla (cc @sgenzer huh? :( )

    Anyway, don't reinstall RapidMiner Server. Here are the files and lines you have to change to change the port to something different. Notice that if you don't use the Radoop Proxy, you won't have the second. Same with the job agent.

    configuration/standalone.xml
    <socket-binding name="http" port="8080"/>

    radoop-proxy/proxy.properties
    serverAuthenticationPort=8080

    job-agent/home/config/agent.properties
    rapidminer.server.port = 8080
  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager
    sorry about that @rfuentealba. If you can replicate pls let me know.
Sign In or Register to comment.