ANNOUNCEMENT: RAPIDMINER 9.1 HAS JUST BEEN RELEASED!   PLEASE DOWNLOAD AND GIVE FEEDBACK. ENJOY AND HAPPY RAPIDMINING!   -- @sgenzer – Community Manager

Select attribute operator doesn't list attributes

udeshika_sewwanudeshika_sewwan Member Posts: 1 Newbie
Hi team,

I have a process that has a Read MongoDB operator, JSON to Data operator and a Select Attributes operator. Read MongoDB and JSON to Data operators execute as usual. But when I try to filter attributes using the Select Attributes operator it doesn't list any attribute to select. But if I use a Retrieve data operator instead of Read MongoDB, the Select Attributes operator works as usual. What may be reasons for this issue?  
Thank you.

Answers

  • Telcontar120Telcontar120 Moderator, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 882   Unicorn
    This is a typically a metadata propagation problem.  You can try to fix it by selecting "Synchronize Metadata with Real Data" option under the Process menu.  If that doesn't work, you can simply type the names of the attributes directly into the right hand panel of Select Attributes and it should work.

    Brian T.
    Lindon Ventures 
    Data Science Consulting from Certified RapidMiner Experts
  • M_MartinM_Martin RapidMiner Certified Analyst, Member Posts: 105   Unicorn
    edited December 10
    Hi:  In addition to the good suggestion from @Telcontar120 , the following steps have (often) worked for me in the situation you describe:

    1. Put a breakpoint after the JSON to Data operator (right click on it, and select the "Breakpoint After" option), 
    2. Click on your "Select Attributes" operator to select it, and then execute your process. 
    3. When your process hits the breakpoint above and halts, click on "Validate Process" on the Process Menu
    4. Click on your "Select Attributes" operator again - and try to select the subset of operators you want.  

    If the above doesn't work, follow steps 1-3 again, and then
    1. Click on your "Select Attributes" operator, right click on it and select the "Breakpoint After" option
    2. Set the "Attribute filter type" to All
    3. Start the process again - it will halt again after the "Select Attributes" operator tries to select all of the attributes in your data set.

    Have all of your attributes been selected?  If so, this is a good sign.  You could then try running the process again from the beginning (but keep the breakpoint that kicks in after your "JSON to Data" operator - but this time set the "Attribute filter type" property on the "Select Attributes" operator to "Subset" and hopefully all of the attributes will appear in the left side of the attribute selection dialog - and you'll be able to select only the attributes you want.

    I've also (sometimes!) been able to solve this problem by exiting and then re-starting RapidMiner and then deleting the "Select Attribute" operator that wasn't working as expected and dragging a new instance of "Select Attributes" on the canvas and hooking it up to other operators in the process - with the result that the new "Select Attributes" operator works as normal.

    As a last resort, you could put a "Store" operator after your "JSON to Data" operator and store the data in your repository, and then retrieve it with a "Retrieve" operator - and then use "Select Attributes" to get the attributes you want.  Storing and retrieving a data set will force a metadata refresh.  Hope this helps, and best wishes, Michael Martin
    hughesfleming68sgenzer
Sign In or Register to comment.