"Loop Attributes - Not Enough Iterations Error"

1705410G1705410G Member Posts: 43 Contributor I
edited May 2019 in Help
I'm trying to make use of my Loop Attributes with Generate Attributes inside of it. I did it with the help of refencing closely to this video (https://academy.rapidminer.com/learn/video/loop-attributes)

However, the "Not Enough Iterations" popped out when I run the process. 

It states that the minimum number of iterations must not be smaller than 1 but was '0'

I don't see anything with regards to 'Iteration' appearing in the above mentioned video as well as in the parameters of Loop Attributes/Generate Attributes. 

How do I solve it?


Best Answers


  • 1705410G1705410G Member Posts: 43 Contributor I
    Hi David_A ,

    I'm using subset. But i'm unsure why this error occurred since there's definitely more than 1 examples.

  • David_ADavid_A Administrator, Moderator, Employee, RMResearcher, Member Posts: 297 RM Research
    Have you by chance checked the reuse results  checkbox and are using a Select Attribute operator inside the loop, or something similar?

    In such a scenario, your reduced subset is passed over to the next loop and then it might be empty.
  • sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager
  • 1705410G1705410G Member Posts: 43 Contributor I
    edited January 2019
    David_A ,

    Yes, I've checked the reuse results box and placed a Generate Attribute operator inside the Loop Attribute.

    So what can I do then? Should I uncheck the reuse results? 

  • 1705410G1705410G Member Posts: 43 Contributor I
    I've solved it! Thank you all for helping!! :):)
Sign In or Register to comment.