🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

Metadata issues - Store/Retrieve

hughesfleming68hughesfleming68 Member Posts: 323   Unicorn
If I had metadata issues in the past I would usually work around them by storing the data set to the repository. Retrieving it would restore the metadata correctly. This would usually happen after an execute R or Python but also transposing a data table. I am finding in 9.21 that this does not work when I run the process. This has nothing to do with the order of the process. To get select attributes for example to see the metadata from a data set retrieved from the repository I have to shutdown and restart Rapidminer and then it works. Running the process with breakpoints sometimes works but when all else fails, restarting Rapidminer is the only option.

On a long process this is a real headache.

regards,

Alex
Tagged:
0
0 votes

Fixed and Released · Last Updated

RM-4031

Comments

  • SGolbertSGolbert RapidMiner Certified Analyst, Member Posts: 344   Unicorn
    Hi Alex,

    you have always the option of synchronizing meta data with real data:


    In general it works, but it's not instantaneous, you may have to run the process a couple of times.


    I agree that the meta data handling doesn't work as expected, this is maybe an issue that has been overlooked in favor of new features.


    Best regards,
    Sebastian

  • hughesfleming68hughesfleming68 Member Posts: 323   Unicorn
    Thanks Sebastian, I tried that but it didn't make a difference.I know where the problem is starting and that it is with execute R. I know I should sort out the metadata inside R but saving to the repository was a quick workaround. Running the process used to be enough to solve that problem.  Restarting Rapidminer and reloading the process fixes this but that is a rather extreme workaround.
  • SGolbertSGolbert RapidMiner Certified Analyst, Member Posts: 344   Unicorn
    I think that when the pipeline goes into the Execute R operator, RapidMiner doesn't have a clue about the output of the operator. A faster workaround could be to have a dataset in the repository with the same attributes but only a few rows and use it for development of the process. That is actually what I also do with big datasets.

    Regards,
    Sebastian
  • hughesfleming68hughesfleming68 Member Posts: 323   Unicorn
    edited March 2019
    To be honest, I think this problem is specific to RM91 and newer. I didn't have this problem with older versions of Rapidminer.

    regards,

    Alex
  • sgenzersgenzer 12Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959  Community Manager
    @hughesfleming68 I have pinged the dev team to see if they can chime in here...

    Scott

  • jczogallajczogalla Employee, Member Posts: 140   RM Engineering

    I do think that it has something to do with how we manage and create metadata since 9.1. We will look into this.
    The thing that is actually happening here is that the Retrieve operator is not updated if the repository entry was created later.
    A workaround for now would be to change the repository location to something different and back again.

    Cheers
    Jan

    @sgenzer, please move this to Product Feedback
    sgenzer
  • hughesfleming68hughesfleming68 Member Posts: 323   Unicorn
    Thanks for the explanation Jan.
  • Telcontar120Telcontar120 Moderator, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,625   Unicorn
    @jczogalla I have been experiencing another problem with Store and Retrieve that I think could be related to metadata and the changes since 9.1.  Studio will sometimes hang when trying to configure the Store or Retrieve path using the file browser that is part of the parameters panel.  It seems to be choking on navigating the repository although there are no problems browsing my repository in the repository window.  You might want to check with Helge Homburg to see whether these problems are related as he has been investigating that issue.
    Brian T.
    Lindon Ventures 
    Data Science Consulting from Certified RapidMiner Experts
  • jczogallajczogalla Employee, Member Posts: 140   RM Engineering
    @Telcontar120 thank you for the hint, will do!
Sign In or Register to comment.