RapidMiner 9.7 is Now Available

Lots of amazing new improvements including true version control! Learn more about what's new here.

CLICK HERE TO DOWNLOAD

"I have encountered this error after log in on Rapid miner program, Ubuntu 18.04.2"

marquizqmarquizq Member Posts: 1 Newbie
edited June 2019 in Help
Exception: java.lang.IllegalArgumentException
Message: null
Stack trace:
java.base/java.util.concurrent.ThreadPoolExecutor.setCorePoolSize(ThreadPoolExecutor.java:1560)
com.rapidminer.extension.concurrency.execution.BackgroundExecutionService.updatePoolSize(BackgroundExecutionService.java:125)
com.rapidminer.extension.concurrency.execution.BackgroundExecutionService.access$000(BackgroundExecutionService.java:71)
com.rapidminer.extension.concurrency.execution.BackgroundExecutionService$2.handleLicenseEvent(BackgroundExecutionService.java:112)
com.rapidminer.license.internal.DefaultLicenseManager.handleLicenseEvent(DefaultLicenseManager.java:1219)
com.rapidminer.license.internal.DefaultLicenseManager.setActiveLicense(DefaultLicenseManager.java:509)
com.rapidminer.license.internal.DefaultLicenseManager.storeNewLicense(DefaultLicenseManager.java:419)
com.rapidminer.core.license.ProductConstraintManager.installNewLicense(ProductConstraintManager.java:310)
com.rapidminer.tools.nexus.NexusConnectionManager.installLicenses(NexusConnectionManager.java:116)
com.rapidminer.tools.nexus.NexusConnectionManager.installLicenses(NexusConnectionManager.java:251)
com.rapidminer.tools.nexus.NexusConnectionManager.installAvailableLicenses(NexusConnectionManager.java:204)
com.rapidminer.gui.license.onboarding.EmailVerificationCard$1.run(EmailVerificationCard.java:111)
com.rapidminer.gui.tools.ProgressThread$3.run(ProgressThread.java:561)
java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1135)
java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)
java.base/java.lang.Thread.run(Thread.java:844)

Answers

  • rfuentealbarfuentealba Moderator, RapidMiner Certified Analyst, Member, University Professor Posts: 513   Unicorn
    Hello, @marquizq

    I may be wrong, but this error message looks like the one coming from trying to use RapidMiner with Java 11/12, which is not supported yet, I think. Make sure you install and activate Oracle Java 8 and set the $JAVA_HOME variable before starting RapidMiner Studio.

    To confirm this, if you could give us the output of executing java -version on a Terminal, it would be great help.

    All the best,

    Rodrigo.
    varunm1sgenzerjczogalla
Sign In or Register to comment.