🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

Rapidminer GUI font rendering problem

hsanchezhsanchez Member Posts: 10 Contributor II
Hello
I have been working with rapidminer for sometime and I have identified a few glitch in its GUI. First issue was broken GUI that I think was caused by Java system. Here is how I solved that:
1-Edit "RapidMiner-Studio.bat" and change the following line 
"%JAVA%" %JVM_OPTIONS% -Dsun.java2d.d3d=false -Dsun.java2d.ddoffscreen=false  -Dsun.java2d.noddraw=true -cp "%RAPIDMINER_HOME%"\lib\*;"%RAPIDMINER_HOME%"\lib\jdbc\* com.rapidminer.launcher.GUILauncher %CMD_LINE_ARGS%
2-I run the .bat file and the GUI broken is solved. If run the .exe the problem still persist.
Procedures such as change compatibility mode never work in my computer (ASUS LAPTOP 64GRAM, Double NVIDIA GeForce GTX 1080 Windows 10)

Everything have been smooth with that patch until today. Pls look at the fonts of the menu.
Has anyone faced this problem before? Language and keyboard are set both to USA language.  
Thank you very much
Tagged:
0
0 votes

Fixed and Released · Last Updated

IC-1544

Comments

  • hsanchezhsanchez Member Posts: 10 Contributor II
    I forgot to mention that it happens with version 9.2, 9.3 or 9.4 (beta which I have been testing its maps visualization capability). I uninstall the software and installed again and the fonts appears as the attached figure.
  • sgenzersgenzer 12Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959  Community Manager
    hi @hsanchez - wow that's a new one. Thank you for this. I'm moving this to Product Feedback and reporting the bug internally. Can you pls do me a favor and send your .RapidMiner folder to me (zip, gz, etc.. is fine) via PM or email? Thanks.

    Scott
  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Administrator, Moderator, Employee, Member, University Professor Posts: 1,963   RM Engineering
    edited August 2019
    Hi,

    Pardon my ignorance, is that a translation in the menus or just random gibberish?
    To be honest, this does not look like a bug on our end and certainly does not look like something we can fix.
    Could be a hardware fault, maybe in the RAM, or something is seriously broken with your OS installation..
    I also don't quite understand the description of the problem, what problems did you experience, and what did the changes to the CMD arguments do to fix them?

    Regards,
    Marco
  • hsanchezhsanchez Member Posts: 10 Contributor II
    Hello Marco_Boeck , yes it is gibberish as you said. In my post I mentioned two problems I faced with RM. The first (1) related with a broken GUI (I think this is a problem others mentioned before and it is related with Java and Nvidia Hardware? ) I fixed that problem and so far RM works well by running the .bat file. 
    The second problem (2) I faced just yesterday after running RM the beta (9.4). Ok Let me give more details. Last modification I did in my OS was installing  Chinese (Language) to be used in Microsoft word. After that I didn't run RM again. Just yesterday, I did by starting the beta version (9.4) and the problem appeared. I set the language just to English (US) and removed any other just to check if the problem is fixed; but nothing.   
    Marco_Boeck mate, all my software installed in my laptop are running smoothly and no dramas so far with any GUI. In fact, RM need to be started in my laptop with the .bat file which I modified (1) and always has been running like this smoothly but that shouldn't be like that. I should be able to execute the .exe as normal. But if I run the .exe the GUI appears broken; if you wish I can send you a pic of that; but as mentioned I run the .bat with some modification and the problem (1) is fixed.
    For your information problem (1-fixed) happens in my two ASUS REPUBLIC OF GAMERS (Both laptop are very high end, one of them has one NVIDIA CARD 32 GBRAM and the second Double NVIDIA GeForce GTX 1080 and 64 GBRAM). Both laptops using external cooling. 

    Problem (2) fonts rendering in the GUI, I suspect that may be related with the installation of Chinese language in windows 10 ; but this problem does not manifest in any other software I have installed in my laptop; just in RM GUI. I was wondering if anybody else in the community has seen something like that before. 
    Thank you
  • hsanchezhsanchez Member Posts: 10 Contributor II
    Hello @sgenzer the file is very large more than 1.6 Gb; let me find a way to send it to you. Thank you
  • hsanchezhsanchez Member Posts: 10 Contributor II
    Dear All, I fix the problem! I removed the .RapidMiner folder and start RM again and problem of the font in the GUI is solved! now back to normal. So you guys Marco_Boecksgenzer may conclude what went wrong. I still keep the .RapidMiner old folder in another drive.
    Thank you
  • jczogallajczogalla Employee, Member Posts: 140   RM Engineering
    Can you please send your rapidminer-studio-settings.cfg file from that old folder? We might eb able to see what went wrong there.

    Best,
    Jan
Sign In or Register to comment.