RapidMiner 9.7 is Now Available

Lots of amazing new improvements including true version control! Learn more about what's new here.

CLICK HERE TO DOWNLOAD

Logistic Regression on regression problem throws error

fschmfschm Member Posts: 6 Contributor I
edited August 2019 in Help
Hi there,
so I'm trying to fit the Logistic Regression operator (regular one, neither SVM or Evolutionary) on a regression problem (numerical label).
Therefore, I set the label attribute as label and convert it with Numerical2Binominal and throw it into a cross validation subprocess with the logistic regression in it.
Afterwards I would reconvert both label and prediction back to numerical and assess the regression performance.
Now, when running the Logistic Regression operator in the training phase throws the following error:
'Model training error (H2O).
Error while training the H2O model: Illegal argument(s) for GLM model: ERRR on field: _response: Response cannot be constant.'
The issue is: I don't have any attribute called reponse or similar. Even outputting the data before the Log. Reg. operator does not show any sign of 'response'.

So, any idea how to fix or bypass this?
Any help is appreciated.

Fabian

<?xml version="1.0" encoding="UTF-8"?><process version="9.3.001">


Tagged:

Best Answer

Answers

  • fschmfschm Member Posts: 6 Contributor I
    Hey guys, appreciate your input.
    @hughesfleming68 thanks so much. Kind of feeling stupid right now. Changed the max. parameter and it worked.
    Now only have to play around with the labels for the performance operator :)
    varunm1Tghadially
  • hughesfleming68hughesfleming68 Member Posts: 298   Unicorn
    I am glad that worked for you @fschm.

    regards,

    Alex
    Tghadially
Sign In or Register to comment.