how can i uninstall the rapidminer server

lzulzu Member Posts: 10 Contributor I
edited September 10 in Help
i installed the rapidminer server on the centos 7 .
then i want to reinstall it 
how can i uninstall the rapidminer server ?
Tagged:
Tghadially

Best Answer

  • mmichelmmichel Posts: 100   RM Engineering
    Solution Accepted
    Hi LiuWenlong,

    the table creation seems to fail:
    15:22:19,660 ERROR [org.hibernate.tool.hbm2ddl.SchemaUpdate] (ServerService Thread Pool -- 64) HHH000388: Unsuccessful: create table ra_ent_group (groupName varchar(255) not null, assignToNewUsers boolean not null, description varchar(255), mirror boolean, singleton boolean not null, special boolean not null, primary key (groupName))
    due to
    Specified key was too long; max key length is 767 bytes
    What DB version are you using? I guess MySQL 5.6 in combination with utf8mb4 encoding? Sadly this configuration will not work out of the box. The best way to overcome this limit would be to use the latest MySQL 5.7 Server or to use another encoding.

    Hope this helps,
    Marcel

Answers

  • lzulzu Member Posts: 10 Contributor I
    Thanks Marcel and Balázs,

    I have reinstalled RM server , and no errors .
    but when  i startup it,  other errors have occurred.

    1.the server is trying to connect to an activeMQ server ,but time out , Do I need to start an activeMQ server before I start the RM server ?
    2.Some error messages show that some of the tables on mysql don't exist, but I don't see the part of the table in the document, how do I create tables in mysql?

    I don't speak english very well, I hope you can understand what I mean.

    LiuWenlong , a Chinese student at LanZhou University
  • lzulzu Member Posts: 10 Contributor I
    10:32:49,937 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-10) MSC000001: Failed to start service jboss.network.management: org.jboss.msc.service.StartException in service jboss.network.management: JBAS015810: failed to resolve interface management
            at org.jboss.as.server.services.net.NetworkInterfaceService.start(NetworkInterfaceService.java:103) [jboss-as-server-7.5.0.Final-redhat-15.jar:7.5.0.Final-redhat-15]
            at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1980) [jboss-msc-1.1.5.Final-redhat-1.jar:1.1.5.Final-redhat-1]
            at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1913) [jboss-msc-1.1.5.Final-redhat-1.jar:1.1.5.Final-redhat-1]
            at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [rt.jar:1.8.0_152]
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [rt.jar:1.8.0_152]
            at java.lang.Thread.run(Thread.java:748) [rt.jar:1.8.0_152]
  • mmichelmmichel Employee, Member Posts: 100   RM Engineering
    Hi LiuWenlong,

    the server is trying to connect to an activeMQ server ,but time out , Do I need to start an activeMQ server before I start the RM server ?

    The ActiveMQ Broker should start automatically with RapidMiner Server. For troubleshooting please upload the server.log file (you can find this one in the log directory of the server home).


    Some error messages show that some of the tables on mysql don't exist, but I don't see the part of the table in the document, how do I create tables in mysql?

    This messages should only appear during the first start of RapidMiner Server and indicate the creation of the tables. So, no manual steps required on your end.


    Cheers,

    Marcel

    lzu
  • lzulzu Member Posts: 10 Contributor I
    edited September 11
    thanks Marcel,

    i upload my server.log and RMS_installer.xml ,Some of RMS_installer.xml been hidden by me.

    now i installed RM server ,but when i trying to start is, The startup script stays at the server.log display,
    The startup script stays at the server.log display,  and i can`t access   myhost:8080 .

    i trying to access myhost:9990 ,i see 'Welcome to JBoss EAP 6' , Looks like the jBoos server is already started.

    and here's the tables that mysql automatically created.
    I can't find the tables that appear in the error log in the database.


    What am I supposed to do now ? 

    Thanks again,
    LiuWenlong 


     

  • lzulzu Member Posts: 10 Contributor I
    thanks Marcel,

    I changed the encoding to GBK, it worked, thank you very much for your help.



    LiuWenlong
    Tghadially
Sign In or Register to comment.