Cannot parse data sets contents

nevsnevs Member Posts: 3 Newbie
I want to use the following data set but when I tried to import it (Turbo Prep), I got an error (see screenshot). 
Is there any way to fix it? 

Data set: "FIFA 19 complete player dataset" from kaggle (can't post any links).



  • Options
    David_ADavid_A Administrator, Moderator, Employee, RMResearcher, Member Posts: 297 RM Research
    Hi @nevs ,

    did you do any pre-processing with the file?
    I have just downloaded the data set from kaggle and it worked fine for me.
    The error you see, states that somewhere in the column "Aggression" the value is "58-10", which is of course not a correct number format.
    What rarely can happen is the following, RapidMiner takes a look at the first hundred lines of the data sets and estimates the type (number, date, string). If then somewhere further down in the document there occurs an entry like "58-10" the code stumbles. When you are using the "Read CSV" operator in this case there are options like "read all values as polynomials" and "read not matching values as missings".
  • Options
    nevsnevs Member Posts: 3 Newbie
    Thanks for your answer but I made a mistake, sorry! 
    The name of data set is "FIFA 18 Complete Player Dataset" not Fifa 19... 
    It is from the user Aman Shrivastava on Kaggle. 

Sign In or Register to comment.