The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

How can I change the maximum memory setting for RM Server on Azure?

DrhelpDrhelp Member Posts: 17 Contributor II
edited March 2020 in Help
My first post here and new to RM.
How can I change the maximum memory setting for RM Server?
I'm using it on Azure and it keeps running out of memory because the configured max limit is 2GB but the licence limit is over 60GB. I thought I found a solution online but it seems to only apply to RM Server installed on pc/mac. Pls help!
Tagged:

Best Answer

Answers

  • Options
    MelihckMelihck Member Posts: 8 Learner I
    Hi there, I am using 9.9 version of RM AI HUB  on Azure. 

    But when I tried to change allocated memory via "public-ip:5080" got an "invalid configuration" error.

    @Sharan_Gadi do you have an idea, how can I solve this?

    Thanks in advacne.
  • Options
    Sharan_GadiSharan_Gadi Administrator, Moderator, Employee, Member Posts: 6 RM Team Member

    Looks like there is a synchronization issue between the deployment manager and the actual compose files. You can also make these changes to the docker compose files once you login into the terminal/server and modify the .env file under /rapidminer folder.
    Following are the properties :
    SERVER_MAX_MEMORY=2048M
    JOBAGENT_CONTAINER_MEMORYLIMIT=2048
    After you make changes  - you can restart the instance from Azure portal to take effect.

    Thanks

Sign In or Register to comment.