RapidMiner Server installer not starting on a mac

DrhelpDrhelp Member Posts: 17 Contributor II
edited November 2019 in Help
Trying to install RapidMiner Server on a mac but the installer is not starting. Please see below and any help would be deeply appreciated. Thank you.
INFO: ----------------- Started installer -----------------

Exception in thread "main" java.lang.NoClassDefFoundError: javax/xml/bind/DatatypeConverter

at com.rapidminer.license.product.DefaultProduct.createBase64Representation(DefaultProduct.java:169)

at com.rapidminer.license.internal.DefaultLicenseManager.verifyProduct(DefaultLicenseManager.java:1073)

at com.rapidminer.license.internal.DefaultLicenseManager.registerProduct(DefaultLicenseManager.java:260)

at com.rapidminer.server.installer.license.LicenseManagerInitializer.initialize(LicenseManagerInitializer.java:31)

at com.rapidminer.server.installer.Starter.main(Starter.java:75)

Caused by: java.lang.ClassNotFoundException: javax.xml.bind.DatatypeConverter

at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:583)

at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)

at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)

... 5 more


Saving session...

...copying shared history...

...saving history...truncating history files...


[Process completed]

Best Answer

  • Options
    DrhelpDrhelp Member Posts: 17 Contributor II
    Solution Accepted
    Thank you for responding rfuentealba. Unfortunately, that didn't work for me. I got this back: Unable to find any JVMs matching version "1.8". But you rightly diagnosed the problem and gave me some ideas.

    Though I had installed Java 8 before, typing "java -version" into the Terminal showed my system reckoned with Java 11. After checking possible other solutions and experimenting, the following worked for me:

    1. Open the .bash_profile file (in TextEdit) on the mac.
    For me, it seemed the file didn't exist based on what I got back on the Terminal. I'll come back to that later. 
    2. Edit the .bash_profile file with the following line: export 
    JAVA_HOME='/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home'
    3. Save the edited 
    .bash_profile file
    4. Open a new terminal window (and type java -version) to check. And the following confirm the change:

    java version "1.8.0_231"

    Java(TM) SE Runtime Environment (build 1.8.0_231-b11)

    Java HotSpot(TM) 64-Bit Server VM (build 25.231-b11, mixed mode)

    As previously noted, there was a problem bringing up the .bash_profile file. I did the following to solve it:  
    1. Start up the Terminal.
    2. Type "cd ~/" to go to the home folder.
    3. Type "touch .bash_profile" to create new file.
    4. Type "open -e .bash_profile" to open it in TextEdit.
    I found a few lines there relating to python and anaconda, which suggested to me that the file existed somewhere before and I don't know why it was not coming up before.


  • Options
    rfuentealbarfuentealba Moderator, RapidMiner Certified Analyst, Member, University Professor Posts: 568 Unicorn

    You are using Java 9 or superior. RapidMiner uses Java 8 because some third party libraries haven't been updated to newer versions yet.

    Install Java 8, and execute the following in the Terminal:
    JAVA_HOME=<span>"$(/usr/libexec/java_home -v 1.8)" /path/to/rmserver/install.sh</span>

    Let me know how it goes.

    All the best,

Sign In or Register to comment.