Process runs fine if it has breakpoints. Otherwise it errors out.

pblack476pblack476 Member Posts: 83 Maven
edited December 2019 in Help
So I have this process. A big complex one with both an SVM and a GBT predicting on Multiple Labels inside a loop file operator. (So multiple labels on multiple datasets)

It errors out near the end with "eval function cannot parse value: -Infinity" type error on a generate macro process.

Now, if I introduce any breakpoint on the process it runs fine. The whole thing takes about 20 minutes per DataSet to run. And I am trying to run it on 4 Datasets. With breakpoints it finishes as expected. But without it throws this error near the conclusion on the 1h mark more or less.

I have created a Dummy process without parameter optimization to have an easier time debugging it and to my surprise, this quick and dirty version finished as expected without breakpoints. It seems that somewhere along the way the process is forgetting a macro and throwing this error while if I run a lighter version (or even the original process with just 1 DataSet instead of 4) it also completes.

Is this type of issue known? It really seems like a bug to throw out -Infinity in place of where a macro should be.

In any case I shall try and work around this but any input is appreciated.

Best Answer


  • Options
    pblack476pblack476 Member Posts: 83 Maven
    @kayman I have tried disabling it on the loop files operator to no success. I am now running with parallell processing disabled throughout all of the inner processes that have that option as well to see if it improves the situation.
  • Options
    pblack476pblack476 Member Posts: 83 Maven
    @kayman It worked. When I disabled every parallell execution in the inner processes the whole thing worked. Thanks!
Sign In or Register to comment.