RapidMiner Wisdom Banner

MongoDB atlas connection

BautastenBautasten Member Posts: 7 Contributor I
Hi,
I'm trying out RapidMiner 9.5 and i'm quite liking it thus far, my two showstoppers are connections to google bigquery (now solved) and connection to MongoDB atlas. I'm trying to get the MongoDB-connection working but having some troubles that I guess are related to me being a complete newbie on the platform, I have set up a connection that tests OK but when trying to use a read MongoDB operator I can't get the collection to list. I'm using a connection string in the connection like "mongodb+srv://.

I notice that the compatibility on the read MongoDB operator states "9.3.000" those that have an impact?

What I'm I doing wrong?
Jasmine_

Best Answer

  • BautastenBautasten Posts: 7 Contributor I
    Solution Accepted
    It was typo error in the DB name so now solved

Answers

  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Administrator, Moderator, Employee, Member, University Professor Posts: 1,873   RM Engineering
    edited January 8
    Hi,

    Are you certain you have access to the collection with your credentials? Do you see any error in the log?
    The highest compatibility refers to the latest available version of the source of an operator, in this case the NoSQL extension. That currently sits at 9.3.0, so that is fine.
    I do get collections from our test instance, though that one is installed locally on one of our servers, not Atlas. I don't know if that changes anything, tbh.


    Regards,
    Marco
    sgenzerJasmine_
Sign In or Register to comment.