How do I specify my Teradata database connection authentication mechanism as LDAP

ecbeam1ecbeam1 Member Posts: 3 Contributor I
edited January 22 in Help
Hello,

I've configured the Teradata drivers according to RapidMiner documentation and verified that I am entering the correct host and port details with my IT department but I still get an error from Teradata saying my account name/account/password is incorrect.  I've had the same issue with other analytic applications but have been able to specify the Authentication as LDAP and the issue was resolved.  However, I am unable to find any such option in RapidMiner to tell it that the connection is LDAP.  Is this possible to do?
Jasmine_

Best Answers

  • ecbeam1ecbeam1 Posts: 3 Contributor I
    edited January 23 Solution Accepted
    Solved it!

    Leaving all settings in the screenshot above as-is, in the Host field I had to put "servername/LOGMECH=LDAP,username,password"

    Thank you Marco_Boeck for putting me on the right track!

Answers

  • ecbeam1ecbeam1 Member Posts: 3 Contributor I
    Hi Marco_Boeck,

    I tried the proposed solution and received the following error

    [Teradata JDBC Driver] [TeraJDBC 16.20.00.13] [Error 1035] [SQLState HY000] Authentication Mechanism LDAP:1035/ not supported on this machine.

    This confuses me because I'm using LDAP Authentication Mechanism for both Tableau and Spider(Python) without errors.

    Below are my connection and driver details and I'm using RapidMiner 9.5.001.  FYI I tried legacy database connection setup as well with the same error. Also tried leaving port blank but it threw an error until I filled it in.




    Jasmine_
Sign In or Register to comment.