Problem with downloading Rapidminer Server

ShineTShineT Member Posts: 4 Learner I
hey, when I tried to download rapidminer, i downloaded the packages and had the rapid-server installer ran by java. But besides showing the following codes as the picture shows, nothing else happened. I have downloaded a PostgreSQL and pgAdmin. Can you help me identify the problem?



Answers

  • sgenzersgenzer 12Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,873  Community Manager
    hi @ShineT - just to make sure...you are following these steps, right? https://docs.rapidminer.com/latest/server/install/
    Pavithra_Rao
  • ShineTShineT Member Posts: 4 Learner I
    Hi @sgenzer, yes I have followed these steps.
  • Pavithra_RaoPavithra_Rao Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 100  RM Data Scientist
    Hi @ShineT,

    Looks like java error, what's the version of the Java you have it installed on this machine?
    Please review the system requirements here.
    https://docs.rapidminer.com/latest/server/install/system-requirements.html

    Cheers,
    Pavithra
  • ShineTShineT Member Posts: 4 Learner I
    Hi @Pavithra_Rao,

    I have downloaded java 8 from Oracle: macOS x64 Installer. I tried to run the installer again but it still didn't work and showed the same codes I pasted on my original post.
  • ShineTShineT Member Posts: 4 Learner I
    Hi @Pavithra_Rao,

    So I have changed my macOS setting to use zsh. And here is the updated code that showed up after I clicked the installer:



    I have also tried to re-download the java and it turned out to be the same result.

    Thanks,
    Shine
  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Administrator, Moderator, Employee, Member, University Professor Posts: 1,908   RM Engineering
    Hi,

    This precise error is caused by using Java 9+. For the time being, RapidMiner requires Java 8.
    This means when starting Server, Java 9+ is still being used.

    Regards,
    Marco
    sgenzer
Sign In or Register to comment.