RAPIDMINER 9.7 BETA ANNOUNCEMENT

The beta program for the RapidMiner 9.7 release is now available. Lots of amazing new improvements including true version control!

CLICK HERE TO DOWNLOAD

An issue with read csv

bernardo_pagnonbernardo_pagnon Member, University Professor Posts: 52  University Professor
Hello all,

so, I am trying to read a csv file, but I noticed something strange. If the first row has 4 entries, and the second row 5 entries, RM only reads the first 4 entries of the second row! It seems that the first row defines how many rows will be read. How can I fix the problem? I have thousands of rows, and I don't want to get into my database to find the row with the largest number of columns.

Regards,
Bernardo 
Tagged:

Best Answer

Answers

  • bernardo_pagnonbernardo_pagnon Member, University Professor Posts: 52  University Professor
    It did the trick, thanks Jacob!

    Best,
    Bernardo

  • jykimjykim Member, University Professor Posts: 4  University Professor
    I am having the same problem. And, I like the trick. Thanks to jacobcybulski. However, though typing enough extra commas will solve the problem, it doesn't sound convenient. Best semi-automatic way is probably to move a row with the longest list of columns to the first row. But I wish there was a way to do this automatically through RM setting. Any parameter changes or or setting to do it automatically? I am trying to do Create Association Rules through FP-Growth. So the data set is a grocery shopping data.
  • Telcontar120Telcontar120 Moderator, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,360   Unicorn
    In the Read CSV operator you can specify which row you should use as your header row, so you can always just pick your longest row and use that (and then rename your attributes as needed).
    Brian T.
    Lindon Ventures 
    Data Science Consulting from Certified RapidMiner Experts
Sign In or Register to comment.