wrong and different results on Association Rule Process

Chris_163Chris_163 Member Posts: 4 Contributor I
I'm using Rapidminer 9.6.0 in Mac since a couple of weeks:

Im running an Association Rule Process for Text Mining like discribed in the Tutorial and a friend of mine gets different results with the identical Process (using my process).

And I think I don't get the right results for ITEM Sets from FG-Growth.
So the Rules are also not correct. I don't find a good tutorial identifying my mistakes.
Do you have some advice how I get the Itemsets for my Text Tokens?

Thanks

Answers

  • bernardo_pagnonbernardo_pagnon Member, University Professor Posts: 57 University Professor
    Hello Chris,

    I also had issues when I started using FP-Growth. It is hard to help you given the broad description you gave, but one advice I have is to be careful with the "find min number of itemsets option". Make sure the comparison you are doing with your friend has either this option checked + the same min requirement, and this option unchecked and all parameters set to the same values.

    You also have to be careful with the "positive value" option. If you don't select the appropriate value here you will get no errors and meaningless output.

    I hope this helps.

    Best,
    Bernardo
  • Chris_163Chris_163 Member Posts: 4 Contributor I
    Hello Bernardo,
    Thanks for your advice and this does not work with my process.
    Yes my college run the process without any changes or other settings than me and displays different results.

    I want to see which ITEMSETS can I see from Recipes Single Token and 2-gram (Token).
     
    I wanted to use the WRITE Operator, but this also do not work and there is nothing mentioned on Rapidminer Tutorial to get the Data for Itemsets. Wanted to show you here.

    And I found the attachment option so now you probably can see what my mistake is.
    Thanks for giving advice here :) 

    Thanks and Best
    Chris-Romano










  • Chris_163Chris_163 Member Posts: 4 Contributor I

  • bernardo_pagnonbernardo_pagnon Member, University Professor Posts: 57 University Professor
    Hi Chris,

    I cannot spot the problem just by looking at the screen shots. I wanted to reproduce the results in my computer: can you please paste the XML of your process here?


    Please attach the data, so I can see which output I get and let you know.

    Best,
    Bernardo


    Jasmine_
  • Chris_163Chris_163 Member Posts: 4 Contributor I
    Hallo Bernardo,

    thanks for support and climb the next level with exporting all the data from Rapidminer.
    Attached you should find the process and data example.

    Many Thanks for support.
    I just reinstalled my rapidminer, but this also doesn't help.

    Thanks and Best
    Chris-Romano
Sign In or Register to comment.