Options

Visualization is not working at all

ShouryaShourya Member Posts: 5 Newbie
Hello,
I am using the most recent version of Rapidminer studio in Ubuntu 18.04
After importing a CSV file, I wanted to make some visualizations and after importing and connecting to the output I press the run process button on the top. Then when I go to visualizations I get only blank screens. Please help.

Best Answer

  • Options
    ShouryaShourya Member Posts: 5 Newbie
    Solution Accepted
    I tried a new beta version and ultimately it worked without changing anything.

Answers

  • Options
    jacobcybulskijacobcybulski Member, University Professor Posts: 391 Unicorn
    It seems you have the wrong version of Java installed on your system - probably too new, e.g. Java 10. Carefully read the "Prerequisites" section of the installation instructions for RapidMiner and see what Java version you must have on your system - at the moment it must be Java 8.
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    What does the ~/.RapidMiner/rapidminer-studio.log file say?

    Regards,
    Marco
  • Options
    jacobcybulskijacobcybulski Member, University Professor Posts: 391 Unicorn
    edited April 2020
    @Shourya , It is worth checking what @Marco_Boeck is suggesting.
    However, I had exactly the same problem on my Ubuntu 18.04 and could not get rid of it, until I installed Oracle Java 8 (not a default OpenJDK. Also make sure that it is Oracle Java 8 which used as a default on your system. Try the following:
    $ java -version
    java version "1.8.0_181"
    Java(TM) SE Runtime Environment (build 1.8.0_181-b13)
    Java HotSpot(TM) 64-Bit Server VM (build 25.181-b13, mixed mode)
    $ sudo update-alternatives --config java
    [sudo] password for jacob: xxxx
    There are 3 choices for the alternative java (providing /usr/bin/java).

      Selection    Path                                            Priority   Status
    ------------------------------------------------------------
      0            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1111      auto mode
      1            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1111      manual mode
      2            /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java   1081      manual mode
    * 3            /usr/lib/jvm/java-8-oracle/jre/bin/java          1081      manual mode

    Press <enter> to keep the current choice[*], or type selection number:
    At this point you will be able to select Java which works with RapidMiner. In my case, this solved the problem.

    Jacob
  • Options
    jacobcybulskijacobcybulski Member, University Professor Posts: 391 Unicorn
    Well done @Shourya , I was not that lucky :smile:
Sign In or Register to comment.