RapidMiner 9.7 is Now Available

Lots of amazing new improvements including true version control! Learn more about what's new here.

CLICK HERE TO DOWNLOAD

Reconfigure Connections to Databases on the new AI Hub 9.7

BierseppBiersepp Member Posts: 6 Contributor I
Hello, 

I recently upgraded RM Server to AI hub on 9.7. This implementation was done in Docker on a Windows Server 2019 environment.
I just realized that the current connections on the Server instance are not working anymore. In Studio everything has been tested successfully. 

On AI Hub I get the following message: 
The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption. Error: "java.security.cert.CertificateException: Certificates do not conform to algorithm constraints". ClientConnectionId:78adaf2a-004a-40d8-b39e-bd04c119f578 

We don't have SSL enabled on the AI Hub. This hasen't been an issue since the latest upgrade. I guess KeyCloak might have something to do with it!?

Thanks for your help. We depend on this for a couple of WebApps we have deployed. 

Tagged:

Best Answers

  • BierseppBiersepp Member Posts: 6 Contributor I
    Solution Accepted
    @aschaferdiek
    Hi thank you for your answer. This helped a lot. 

    On a side note, I also had to additionally change the driver to Microsoft SQL Server to jdbc:jdts. But without the URL changes it would not have worked. 

    Thanks again!

Answers

  • sgenzersgenzer 12Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,952  Community Manager
Sign In or Register to comment.