AI server docker restart

kaymankayman Member Posts: 662 Unicorn
edited August 2020 in Help
Probably missing something but after I managed to get the server running under docker it fails to start again after a reboot. I've been going through all of the content but can find only info on how to install fresh, not how to deal with an existing installation.

I'm running on Linux, error given is RMSSOAuthenticator error, failed to load IDP configuration

Can someone tell me in simple steps how I can (re)start my docker image, or check if all required components are running to start with?

Tagged:

Answers

  • BierseppBiersepp Member Posts: 14 Contributor II
    edited August 2020
    I did once have the same problem, when I changed from a standalone version to docker. In my case it was an issue with the SQL Server configuriation in your .env file. Maybe this helps.


  • aschaferdiekaschaferdiek Employee, Member Posts: 76 RM Engineering
    Hi. If you're using our docker compose, you can verify via docker-compose ps and look at the container names. They should match in name and amount of containers from the docker-compose.yml file. You can (re)start individual docker containers with docker-compose <serviceName> <action>, e.g. docker-compose rm-keycloak-svc stop or docker-compose rm-keycloak-svc start.
    If this doesn't solve your problem, then please provide additional logs so we can dive deeper into this.


  • sumancologysumancology Member Posts: 5 Contributor II
    Biersepp,  How did you configure the SQL server to resolve the "RMSSOAuthenticator error, failed to load IDP configuration" issue:?  Can you point me to a Sample of PostgreSQL Server configuration in (.env) file
  • BierseppBiersepp Member Posts: 14 Contributor II
    Hello @sumancology,
    you might first want to checkout if the database configuration is the problem whether your docker instance does not start up properly. The error might appear also when other paramters aren't configured right.
    If you use the on-board postgresql Database which is part of the package you better keep the configuration just like described in the RM docs.

    In my case I am using a dedicated mssql database running on the same host. Since I migrated from a standalone to a docker instance. So the configuration has to be slightly different since the path to the database is not part of the docker instance itself: 

    I configured my Rapidminer Server in the .env file as following:
    SERVER_DBHOST=host.docker.internal
    SERVER_DBSCHEMA=rapidminer_server (Insert your schema)
    SERVER_DBUSER=username
    SERVER_DBPASS=password

    Further you need to configure the database type in the docker-compose file: This is important for loading the correct drivers.

    rm-server-svc:
        image: ${REGISTRY}rapidminer-server:${SERVER_VERSION}
        hostname: rm-server-svc
        restart: always
        environment:
          - PA_BASE_URL=${PA_BACKEND}
          - PA_SYNC_DEBUG=False
          - DBTYPE=mssql <-------- Thats where you need to change the database type. 
          - DBHOST=${SERVER_DBHOST}
          - DBSCHEMA=${SERVER_DBSCHEMA}
          - DBUSER=${SERVER_DBUSER}
          - DBPASS=${SERVER_DBPASS}
          - ......
    But you might also be able to do that in your .env file if preferred.

    Hope this helps!
Sign In or Register to comment.