🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

There is insufficient memory for the Java Runtime Environment to continue

HeadPilgrimHeadPilgrim Member Posts: 2 Newbie
edited January 2021 in Help
This is a fresh install on my computer for the 9.8 version of Rapid Miner Studio. I have 32GB of memory so I'm not sure how there could possibly be insufficient memory. I've attached the bat file error that I get as well as the log file.
Please help I need to use RapidMiner for my class. 

Also to note RapidMiner starts fine when I disable extensions but fails when I instead opt to start normally.
Moreover I've looked at recent posts with similar issues however their log files were different or solutions posted did not fix the problem. 
Tagged:

Best Answers

  • HeadPilgrimHeadPilgrim Member Posts: 2 Newbie
    Solution Accepted
    I believe I fixed it by changing my page file size from 0 to just being handled by my system. I believe I changed this previously due to the amount of space it was taking on my SSD. I guess RapidMiner requires a pagefile in order to run extensions or something along the lines of that. 
    hush_0401
  • BalazsBaranyBalazsBarany Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 733   Unicorn
    Solution Accepted
    There is no setting in RapidMiner about a page file. In RapidMiner you can set the maximal memory to use but that only works if Studio starts and you can access the settings windows. 

    What's your problem? 

    In Windows you need to go to the System settings in the control panel, then Advanced Settings, then Performance options. (Translated from my German Windows, it might be different.)

    Regards,
    Balázs
  • BalazsBaranyBalazsBarany Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 733   Unicorn
    Solution Accepted
    Does this happen if you restart your computer and run RapidMiner as the first application?

    Java likes to allocate continuous memory areas. If you run or ran multiple applications, the total available memory might be enough but not in one place. 

    Regards,
    Balázs

Answers

  • BalazsBaranyBalazsBarany Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 733   Unicorn
    Hi @HeadPilgrim,

    thank you for this analysis.

    There is no explicit requirement for a page file from RM extensions to the best of my knowledge. It's probably about the operating system working differently in the situations when it can page out memory and when it can't. For example, if the Java runtime tries to allocate a continuous memory block, this is more likely to succeed if a page/swap file or partition is there. It seems that you hit a corner case where there was a large enough block for RapidMiner alone but not for RapidMiner + extensions.

    Thanks for documenting this.

    Best regards,
    Balázs
  • AndryehAndryeh Member Posts: 5 Learner I
    Sorry to bump an old thread but what is meant by increasing the size of the page file? I know what a page file is but I'm on Windows, which should be handling that automatically, and I don't see anything in the RapidMiner settings about a page file.
  • treble_deathtreble_death Member Posts: 1 Newbie
    I'm getting the same error described as above on my fresh install of RapidMiner on a Windows 10  'there is insufficient memory for the java runtime enviornment to continue' It then lists that the native memory allocation failed to map a certain number of bytes. I have more than that specified number free on my disk and more than the specified number currently allocated for paging file size for all drivers. 

    I went in and made sure my paging file size settings were automatically managed but the error persists. Any other suggestions? 

  • hush_0401hush_0401 Member Posts: 1 Newbie
    I have also solved a similar problem by enabling this setting.

Sign In or Register to comment.