Major GUI rendering problems

AndyBAndyB Member Posts: 2 Newbie
edited April 2021 in Help
Hello,

I am currently using RapidMiner 9.9 and have encountered GUI problems. During my work in program I get something like this.

I have currently tried a couple of thing, but to no avail. What have a I tried:
- reinstalling Java
- reinstalling GPU drivers
- changing Bat file content such as this https://community.rapidminer.com/discussion/comment/47635
- setting GPU to Max performance
- reinstalling RapidMiner
- installed DX9
- disabled the D3D harware acceleration

My PC setup is:
AMD 5950x
64GB ram
 Nvidia RTX 3090

I thank you for any new ideas. 

Best Answers

  • jwpfaujwpfau Employee, Member Posts: 268 RM Engineering
    Solution Accepted
    Hi Andy,

    just to be sure, did you run the RapidMiner-Studio.bat file after adding -Dsun.java2d.d3d=false 
    or the regular Desktop Icon / RapidMiner.exe file?

    Greetings,
    Jonas
  • AndyBAndyB Member Posts: 2 Newbie
    edited May 2021 Solution Accepted
    I run both. Neither was successful at the time. But RapidMiner started working fine on its own three days ago. Not sure if it was a GPU driver update or some Java updates. 

    P.S. I am sorry that I did not look at you answer earlier. Suggested solution that jwpfau wrote could likely help someone else at some point.
    jwpfau

Answers

  • NordineNordine Member Posts: 1 Newbie
    edited November 2021
    Hello,
    I had the same problem. So, it is very difficult to work with Rapidminer
    My PC setup is:
    Windows 10 (system and drivers up to date, including JAVA)
    AMD 3990
    64GB ram
    Nvidia RTX 3080

    I add -Dsun.java2d.d3d=false. It seems to work fine now ! Thanks a lot !


    Greetings,
    Nordine
Sign In or Register to comment.