The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

Cannot Register Renderer - RM reinstalls don't fix

taylorgtaylorg Member Posts: 5 Contributor II
edited May 2021 in Help
When I load any process into RM 9.9, I get the attached error saying "Operator 'Process' was created with version '9.4.000'.

Log file states "Cannot register renderer" and none of the chromium.exe processes load:  Here's a snippet from the log:

INFO: Global Search category repository registered.
May 13, 2021 10:11:18 AM com.rapidminer.tools.plugin.Plugin initAll
INFO: Plugins skipped.
May 13, 2021 10:11:18 AM com.rapidminer.gui.renderer.RendererService registerRenderers
WARNING: Cannot register renderer: com.rapidminer.extension.html5charts.gui.renderer.ExampleSetVisualizationRenderer
java.lang.ClassNotFoundException: com.rapidminer.extension.html5charts.gui.renderer.ExampleSetVisualizationRenderer
    at java.net.URLClassLoader.findClass(URLClassLoader.java:382)

 I've been using 9.9 successfully since it was released several weeks ago - until May 12.  I've reinstalled RM 9.9 multiple times but continue to get the error shown in the attachment when loading any process.

I've tried a clean reinstall of the NVidia driver and installing Google Chrome, each followed by RM reinstalls, but chromium still won't load and the errors are the same..

Also tried editing the RapidMiner-Studio.bat file as suggested in another post - still won't load the GUI:
rem ## "%JAVA%" %JVM_OPTIONS% -cp "%RAPIDMINER_HOME%"\lib\* com.rapidminer.launcher.GUILauncher %CMD_LINE_ARGS%

"%JAVA%" %JVM_OPTIONS% -Dsun.java2d.d3d=false -Dsun.java2d.opengl=true -cp "%RAPIDMINER_HOME%"\lib\*;"%RAPIDMINER_HOME%"\lib\jdbc\* com.rapidminer.launcher.GUILauncher %CMD_LINE_ARGS%

This issue may be related to hardware acceleration enabled by the new NVidia drivers.  Before my machine refused to run RM, javaw.exe was heavily using both the GPU and CPU simultaneously while modeling and computing.  It seemingly worked well.  When the RM process finished, the GPU use would drop back to zero while the RM UI was still open.  Chromium may not have liked this and now refuses to run with my graphics driver (466.27).  If this is the case, I may need to disable HW acceleration or find another graphics driver.

Best Answers

  • Options
    taylorgtaylorg Member Posts: 5 Contributor II
    Solution Accepted
    Fixed this issue by moving User/ .RapidMiner-Studio folder to another drive then a fresh install of RM (requiring manual license validation.)  So, the GUI/Chromium not launching properly doesn't appear to be related to the simultaneous GPU CPU / hardware acceleration issue. 
  • Options
    taylorgtaylorg Member Posts: 5 Contributor II
    Solution Accepted
    The cause of the GUI/Chromium not launching was ultimately found to be deselecting "Initialize extensions" in Settings / Preferences / Startup.  Reselecting "initialize extensions" is a much easier way to solve the GUI issue.

    I was hoping that if extensions were needed, they'd be initialized as needed.  I have many rarely used extensions that take a long time to load at startup.  They probably waste computing resources so deselecting the initialize extensions option seemed attractive.  I need to figure out another way to keep them from loading at startup.
Sign In or Register to comment.