Options

Different Join Result from Studio to Server

BrianTBrianT Member Posts: 5 Learner I
I'm working on joining two rather large datasets together. Due to their sizes, I will have to perform the join on the server. Testing in RMstudio with a fraction of the data from each dataset does what I expect, completing the join successfully. However, when I run the same process with the same test data on the server, the join only adds the names of the new features and records the data as missing. In other words, the same deterministic process is producing different outcomes in Studio and the server.

Any ideas what could be happening here? I'm slightly baffled by the fact that the process completes as expected in Studio but not on the server.
Tagged:

Answers

  • Options
    BrianTBrianT Member Posts: 5 Learner I
    I'll leave this open in case anyone has a similar issue in the future. For now, my problem has been solved. My original process had a handful of steps on one of the datasets before the join. I created a separate process solely to run those steps and Store the output. Running only the join, with no other steps, solved the problem.
Sign In or Register to comment.