🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

Wrong datetime after Write in Database

rademaradema Member Posts: 10 Contributor II
Hi everyone, 

I have process which retrieves data from a database, does some feature engineering and then store the result in another database. 
One of the attributes is a datetime (CET timezone) and I would expect that the destination datetime is equivalent to the source. When I run the process locally, the process works as expected. When I run it on AI Hub (which I think is UTC or GMT), the output is a datetime shifted by 1 hour respect to the source one. Can you tell me how to setup correctly the connection so that it store the right results? I tried few options in the connection settings but no useful result.

Bests

Answers

  • MichaelMichael Administrator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 27  RM Data Scientist
    edited November 2021
    Hi,
    Do you apply any transformations to the date time columns in the process, e.g., conversion to Nominal and back?
    If you do, have you changed the time zone parameter (usually an advanced parameter) to one of the CET values?

    If you don't, have you changed the connection settings discussed here (see accepted answer):
    https://community.rapidminer.com/discussion/comment/68786

    Best,
    Michael
    BalazsBarany
Sign In or Register to comment.