Options

Snowflake JDBC connection help with RM Studio

CarlPCarlP Member Posts: 7 Learner I
Hi has anyone managed to connect RM studio 9.10 to Snowflake using JDBC? No matter what I try I can't seem to get this working. The instructions in the link below dont work and dont apply to v9.10 of RM
docs.rapidminer.com/latest/studio/connect/database/jdbc/
I would truly appreciate some help with this. thanks Carl

Best Answer

  • Options
    shanilashanila Member Posts: 6 Contributor I
    Solution Accepted
    it worked after removing authenticator=externalbrowser&user=abc

Answers

  • Options
    bpimperbpimper Member Posts: 7 Contributor II
    Hi @CarlP,

    What exact settings did You tried to establish the connection?
    I suggest to use a configuration like that:
    After these setting you should provide the JDBC driver Jar file under the Driver tab.
    Make sure you have installed Java 1.8 or higher on your local machine, due to this is a requirement for the Snowflake JDBC driver.

    I hope this will help you out!

    Cheers,
    Bence

  • Options
    CarlPCarlP Member Posts: 7 Learner I
    edited July 2022


  • Options
    bpimperbpimper Member Posts: 7 Contributor II
    Hello @CarlP

    Based on Snowflake documentation the URL should look like that: jdbc:snowflake://<account_identifier>.domain.com/?<connection_params> , i suggest to modify the host and remove the snowflake:// part from that.

    Cheers,
    Bence
  • Options
    CarlPCarlP Member Posts: 7 Learner I
    edited July 2022


  • Options
    bpimperbpimper Member Posts: 7 Contributor II
    Based on the documentation the host url in this case should look like this: jea45817.us-east-1.snowflakecomputing.com , please remove the othe parts of the url.
  • Options
    CarlPCarlP Member Posts: 7 Learner I
    RapidMiner 9.10.008  How to successfully connect using the Snowflake JDBC Driver. The 2 snapshots below show the proper way to configure RM 9.10 to Snowflake.






  • Options
    CarlPCarlP Member Posts: 7 Learner I
    snowflake connection success
  • Options
    shanilashanila Member Posts: 6 Contributor I
    I am getting the error No sutitable driver found for 
  • Options
    jwpfaujwpfau Employee, Member Posts: 302 RM Engineering
    Hi shanila,

    please make sure that the URL prefix is jdbc:snowflake://

    See also this thread https://community.rapidminer.com/discussion/57278/how-to-resolve-no-suitable-driver-found-for-jdbc-snowflake-url-issue-when-connecting-to-snowflake

    Greetings,
    Jonas
  • Options
    shanilashanila Member Posts: 6 Contributor I
    now i am getting a different error which is a number. !390190!


  • Options
    jwpfaujwpfau Employee, Member Posts: 302 RM Engineering
    That's an Snowflake error code, does your Snowflake server require SAML / SSO? 

    You could try to add &authenticator=externalbrowser to the JDBC URL

    Or check the ~/.RapidMiner/rapidminer-studio.log file for more details.
  • Options
    shanilashanila Member Posts: 6 Contributor I

    Unfortunately i cant find log files :(
    or am i looking in a wrong folder?
    we have a trial version
    we dont use SAML/SSO
    this is how i connected

    snowflake://abc.snowflakecomputing.com/?authenticator=externalbrowser&user=abc




Sign In or Register to comment.