attribute_value_filter Missing

EdgarlopezEdgarlopez Member Posts: 4 Newbie
I'm newbie and I was reading some material, but i'm stuck on the filter that applies after a kmeans operator:

The book says that 'Filter Example' node, you will see something like this:



However, no matter how i apply the filters, the menu at right sides is different, without 'parameter string' field:




Does anyone knows why?

Answers

  • MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,282 RM Data Scientist
    Hi,
    I think attribute value filter was buggy, and you can just do it with expression and custom_filter options and thats why we removed it. But I am not 100% sure, @Marco_Boeck do you remember?
    ~Martin
    - Head of Data Science Services at RapidMiner -
    Dortmund, Germany
  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Administrator, Moderator, Employee, Member, University Professor Posts: 1,966 RM Engineering
    Hi,

    Correct. This was a weird syntax that existed purely in that one place and no longer necessary with the powerful Expression Parser und the simple custom_filters having repaced them much more effectively.

    Regards,
    Marco
    MartinLiebig
  • EdgarlopezEdgarlopez Member Posts: 4 Newbie
    So, in other words, the first screenshot is not longer available anymore?
  • MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,282 RM Data Scientist
    if you really really want to, you can change the operators comparability mode to 6.4. This option is on the very bottom of the parameter screen:
    This way you get back the old behavior and as you can see you can use attribute_value_filter.

    Anyhow, there is good reason why we deprecated this option in newer versions. So use this option with caution.

    Best,
    Martin
    - Head of Data Science Services at RapidMiner -
    Dortmund, Germany
Sign In or Register to comment.