Recommendations unavailable | HTML 5 issues | Path issues

ValHrtValHrt Member Posts: 2 Newbie
edited June 6 in Help
Hello,

I'm new to this forum, currently a Data Science student, I've been using RapidMiner for over 6 months now and I've just encountered the following problems with the application when everything was working fine before.

First of all, I can no longer open the application from the Mac's Applications menu. It says that the application is damaged or incomplete. I can still launch it with the shell file from my terminal, but I'd like to know what the problem is and how to solve it. I've deleted the application and downloaded it again, but the problem persists.



The second problem is that when I open RapidMiner Studio, I no longer have access to my files saved in the application. The saved processes no longer appear, even though the access paths are correct. As you can see in the example below, for the Finance_Project folder, the global directory is displayed on RapidMiner, but when I click on it, I can't access the subfolders containing the processes, data and connections, even though the path entered is the correct one. Everything worked perfectly before.





The third problem is that I no longer have access to the recommendations. Here again, everything was working perfectly a few days ago.



Here is the log corresponding to this error:

Jun 06, 2023 4:45:43 PM com.rapidminer.gui.model.RecommendationModel queryRecommendations
WARNING: Failed to request recommendations, returncode 400

Finally, the last problem concerns the fact that HTML5 no longer works, so I no longer have access to the visualizations.



Here is the log corresponding to this error:

Jun 06, 2023 4:47:18 PM com.rapidminer.extension.browser.BrowserFactory init
SEVERE: Failed to initialize the Browser, HTML5 components might not be available!
com.teamdev.jxbrowser.engine.ChromiumBinariesExtractionException: Failed to extract Chromium binaries into /Users/XXXXXXXXXXXXX/.RapidMiner/internal cache/browser7.26-OSX
at com.teamdev.jxbrowser.internal.ChromiumExtractor.extract(ChromiumExtractor.java:50)
at com.teamdev.jxbrowser.engine.internal.EngineImpl.extractChromiumBinariesIfNecessary(EngineImpl.java:422)
at com.teamdev.jxbrowser.engine.internal.EngineImpl.newInstance(EngineImpl.java:149)
at com.teamdev.jxbrowser.engine.Engine.newInstance(Engine.java:163)
at com.rapidminer.extension.browser.BrowserFactory.createEngine(BrowserFactory.java:340)
at com.rapidminer.extension.browser.BrowserFactory.init(BrowserFactory.java:141)
at com.rapidminer.extension.browser.BrowserFactory.createBrowser(BrowserFactory.java:248)
at com.rapidminer.extension.browser.BrowserFactory.createBrowser(BrowserFactory.java:212)
at com.rapidminer.extension.html5charts.gui.chart.implementations.html5.HTML5HighChartsChartGUI.createChartSceneJxBrowser(HTML5HighChartsChartGUI.java:436)
at com.rapidminer.extension.html5charts.gui.chart.implementations.html5.HTML5HighChartsChartGUI$1.doInBackground(HTML5HighChartsChartGUI.java:168)
at com.rapidminer.extension.html5charts.gui.chart.implementations.html5.HTML5HighChartsChartGUI$1.doInBackground(HTML5HighChartsChartGUI.java:164)
at java.desktop/javax.swing.SwingWorker$1.call(SwingWorker.java:304)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.desktop/javax.swing.SwingWorker.run(SwingWorker.java:343)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:829)
Caused by: java.io.FileNotFoundException: chromium-mac-arm.7z
at com.teamdev.jxbrowser.internal.ChromiumExtractor.extract(ChromiumExtractor.java:48)
... 16 more

I'm on Macbook Pro M1, OS Ventura 13.4, OpenJDK11.

I'd like to point out that I had absolutely no problems with RapidMiner before and that overnight all these problems appeared without me changing anything in my files.

If anyone knows what could have caused all these problems simultaneously and how to solve them, I'd be very grateful. I'm using RapidMiner for my thesis and I'm currently stuck with these problems.

Thank you,

Valentin
Tagged:

Answers

  • jwpfaujwpfau Employee, Member Posts: 264 RM Engineering
    edited June 7
    Hi Valentine,

    I sadly don't have an arm mac on hand to reproduce the issues.

    But some things you could try:

    - Instead of putting the RapidMiner Studio App into Applications, try to install it onto your desktop
    - Right click on the RapidMiner Studio App and select "Get Info" in the Info window select "Open using Rosetta"

    For the charts issue when started from the terminal:
    RapidMiner Studio seem to start using a native mac-aarch64 Java installation, but we don't bundle mac-arm binaries yet. You could try to make it start using a mac-x64 Java 11 installation to force Rosetta 2 usage.

    Greetings,
    Jonas


    ValHrt
  • ValHrtValHrt Member Posts: 2 Newbie
    Hi Jonas,

    Thank you very much for your quick reply.

    I've tried to totally de-install RapidMiner Studio including the .RapidMiner directory and re-install it again on my Desktop. The problem remains the same, I can't open the application directly and I have no option to open the application with Rosetta 2 (although the latter is installed on my Mac since I use it for certain applications).






    I also noticed that in the application files there was no exec file in the MacOs directory of the RapidMiner application. Could this be the problem? And if so, what can I do to solve this problem, bearing in mind that I've completely deleted all the RapidMiner files from my Mac and re-installed everything from scratch.



    Greetings,

    Valentin
  • WasakaWasaka Member Posts: 2 Newbie
    Hey,

    I'm encountering the same issue on my end as well. It was functioning correctly for a period of time, but following a recent macOS update, I've also been unable to open RapidMiner.

    Any assistance you can provide would be greatly appreciated.

    Best regards,
    Wassim
  • WasakaWasaka Member Posts: 2 Newbie

    Hello,

    I'm experiencing a similar issue also on Ubuntu 22.04 running on an ARM CPU. Here is the error output:

    RAPIDMINER_HOME is not set. Trying the directory '/home/wasaka/Applications/rapidminer-studio'...
    WARNING: package com.apple.eawt not in java.desktop
    WARNING: package sun.lwawt.macosx not in java.desktop
    WARNING: An illegal reflective access operation has occurred
    WARNING: Illegal reflective access by com.rapidminer.tools.ExtensibleResourceBundle (file:/home/wasaka/Applications/rapidminer-studio/lib/rapidminer-studio-i18n-10.2.0.jar) to field java.util.ResourceBundle.parent
    WARNING: Please consider reporting this to the maintainers of com.rapidminer.tools.ExtensibleResourceBundle
    WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
    WARNING: All illegal access operations will be denied in a future release
    Sep 29, 2023 11:33:12 PM com.rapidminer.tools.PlatformUtilities logInfo
    INFO: Searching in Java classpath for RapidMiner Studio jars...
    Sep 29, 2023 11:33:12 PM com.rapidminer.tools.PlatformUtilities logInfo
    INFO: Trying parent directory of '/home/wasaka/Applications/rapidminer-studio/lib/rapidminer-studio-core-10.2.0.jar'...
    Sep 29, 2023 11:33:12 PM com.rapidminer.tools.PlatformUtilities logInfo
    INFO: Gotcha! 'rapidminer.home' is: /home/wasaka/Applications/rapidminer-studio
    Sep 29, 2023 11:33:12 PM com.rapidminer.tools.PlatformUtilities logInfo
    INFO: Release platform: ANY
    Sep 29, 2023 11:33:12 PM com.rapidminer.gui.license.altair.AltairLicenseDetection readUserLicensePreferencesSetting
    SEVERE: Failed to read RM preferences for user specified license settings: /home/wasaka/.RapidMiner/rapidminer-studio-settings.cfg
    Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/wasaka/.RapidMiner/internal cache/altairLicense15.2.0-ANY/libaljdk.so: /home/wasaka/.RapidMiner/internal cache/altairLicense15.2.0-ANY/libaljdk.so: cannot open shared object file: No such file or directory (Possible cause: can't load AMD 64-bit .so on a AARCH64-bit platform)
    	at java.base/java.lang.ClassLoader$NativeLibrary.load0(Native Method)
    	at java.base/java.lang.ClassLoader$NativeLibrary.load(ClassLoader.java:2450)
    	at java.base/java.lang.ClassLoader$NativeLibrary.loadLibrary(ClassLoader.java:2506)
    	at java.base/java.lang.ClassLoader.loadLibrary0(ClassLoader.java:2705)
    	at java.base/java.lang.ClassLoader.loadLibrary(ClassLoader.java:2635)
    	at java.base/java.lang.Runtime.load0(Runtime.java:768)
    	at java.base/java.lang.System.load(System.java:1850)
    	at com.altair.license.ALJDK.(ALJDK.java:271)
    	at com.rapidminer.altair.license.AltairSetup.setup(AltairSetup.java:99)
    	at com.rapidminer.altair.license.AltairSetup.setup(AltairSetup.java:73)
    	at com.rapidminer.altair.license.AltairSetup.setupOnce(AltairSetup.java:58)
    	at com.rapidminer.altair.license.AltairLicenseHandler.drawStudioUnits(AltairLicenseHandler.java:63)
    	at com.rapidminer.altair.license.AltairLicenseTools.detectLicenseManager(AltairLicenseTools.java:119)
    	at com.rapidminer.gui.license.altair.AltairLicenseDetection.detectLicenseManger(AltairLicenseDetection.java:109)
    
    

    Any assistance you can offer to resolve this would be highly appreciated.

    Best regards, W.


  • jwpfaujwpfau Employee, Member Posts: 264 RM Engineering
    edited October 2
    Hi Wasaka,

    Sadly Linux on ARM isn't officially supported.

    But you can you try to add the line:
    rapidminer.license.preferred_license=RapidMiner License
    to your /home/wasaka/.RapidMiner/rapidminer-studio-settings.cfg (create the file if it doesn't exist yet).

    Greetings,
    Jonas
Sign In or Register to comment.