Import data - no data found error message - CSV

Mark2121Mark2121 Member Posts: 7 Newbie

I had been using the rapidminer for 2 days, I had imported several times the same structure csv, I had, but somehow it started to unrecognized the csv couple hours ago. I tried everything, the message always the same. No data found. "Try changing the column separator.." I checked the column separetor is good, it was good also erlier.

Do you know how I can solve this?




  • Options
    CKönigCKönig Administrator, Moderator, Employee, Member Posts: 70 RM Team Member
    Hi @Mark2121

    Did the underlying CSV files change? Hard to guess here without the actual process and sample of the CSV file.
  • Options
    Mark2121Mark2121 Member Posts: 7 Newbie
    Thank your reply. I attached a sample.

    The process is the initate step, importing to repo. When I choose from library the upload runs error, the error message is pasted below.



  • Options
    CKönigCKönig Administrator, Moderator, Employee, Member Posts: 70 RM Team Member
    I tried importing your sample with the above configuration and  it worked fine (RM 10.2) locally. I had to deactivate "Skip Comments" though, to get all of the columns (one is named KP#, which leads to all following columns being cut off).
  • Options
    Mark2121Mark2121 Member Posts: 7 Newbie
    I am using the same version. At first it worked, later somehow it got wrong, you can see in the pic. Is there any neccesarry settings in the settings, which I need to consider or should I pay attention, maybe I switched it when I want to solve an other problem.
  • Options
    CKönigCKönig Administrator, Moderator, Employee, Member Posts: 70 RM Team Member
    Not from the screenshot. Could you maybe share the process?
  • Options
    Mark2121Mark2121 Member Posts: 7 Newbie
    If I share the process you will be able to open without my repo?
  • Options
    Mark2121Mark2121 Member Posts: 7 Newbie
    Attaching here
  • Options
    CKönigCKönig Administrator, Moderator, Employee, Member Posts: 70 RM Team Member
    Hey @Mark2121

    Can you try to import the CSV with this process? This can probably give you a better error message, if one occurs. Make sure to change the local file path to your file.

    <?xml version="1.0" encoding="UTF-8"?><process version="10.2.000">
      <operator activated="true" class="process" compatibility="10.2.000" expanded="true" name="Process">
        <parameter key="logverbosity" value="init"/>
        <parameter key="random_seed" value="2001"/>
        <parameter key="send_mail" value="never"/>
        <parameter key="notification_email" value=""/>
        <parameter key="process_duration_for_mail" value="30"/>
        <parameter key="encoding" value="SYSTEM"/>
        <process expanded="true">
          <operator activated="true" class="open_file" compatibility="10.2.000" expanded="true" height="68" name="Open File" width="90" x="45" y="34">
            <parameter key="resource_type" value="file"/>
            <parameter key="filename" value="C:/Temp/DTRV_vasarlasok_202310_v2.csv"/>
            <description align="center" color="purple" colored="true" width="126">Change location of the CSV file here!</description>
          <operator activated="true" class="read_csv" compatibility="10.2.000" expanded="true" height="68" name="Read CSV" width="90" x="246" y="34">
            <parameter key="csv_file" value="C:\Temp\DTRV_vasarlasok_202310_v2.csv"/>
            <parameter key="column_separators" value=";"/>
            <parameter key="trim_lines" value="false"/>
            <parameter key="use_quotes" value="true"/>
            <parameter key="quotes_character" value="&quot;"/>
            <parameter key="escape_character" value="\"/>
            <parameter key="skip_comments" value="false"/>
            <parameter key="comment_characters" value="#"/>
            <parameter key="starting_row" value="1"/>
            <parameter key="parse_numbers" value="true"/>
            <parameter key="decimal_character" value=","/>
            <parameter key="grouped_digits" value="false"/>
            <parameter key="grouping_character" value=","/>
            <parameter key="infinity_representation" value=""/>
            <parameter key="date_format" value="yyy-MM-dd'T'HH:mm:ss"/>
            <parameter key="first_row_as_names" value="true"/>
            <list key="annotations"/>
            <parameter key="time_zone" value="SYSTEM"/>
            <parameter key="locale" value="English (United States)"/>
            <parameter key="encoding" value="UTF-8"/>
            <parameter key="read_all_values_as_polynominal" value="false"/>
            <list key="data_set_meta_data_information">
              <parameter key="0" value="Validate.true.integer.attribute"/>
              <parameter key="1" value="UniqID.true.integer.attribute"/>
              <parameter key="2" value="InDateTime.true.date_time.attribute"/>
              <parameter key="3" value="DateTime.true.date_time.attribute"/>
              <parameter key="4" value="Card number.true.real.attribute"/>
              <parameter key="5" value="KP#.true.integer.attribute"/>
              <parameter key="6" value="Pharmacy.true.polynominal.attribute"/>
              <parameter key="7" value="Pharmacy address.true.polynominal.attribute"/>
              <parameter key="8" value="Sum.true.integer.attribute"/>
              <parameter key="9" value="Discount.true.integer.attribute"/>
            <parameter key="read_not_matching_values_as_missings" value="false"/>
            <description align="center" color="transparent" colored="false" width="126">Configured to match the provided sample:&lt;br&gt;&lt;br&gt;encoding set to UTF-8&lt;br&gt;&lt;br&gt;deactivated &amp;quot;skip comments&amp;quot;&lt;br&gt;&lt;br&gt;changed date format to match the two date columns</description>
          <connect from_op="Open File" from_port="file" to_op="Read CSV" to_port="file"/>
          <connect from_op="Read CSV" from_port="output" to_port="result 1"/>
          <portSpacing port="source_input 1" spacing="0"/>
          <portSpacing port="sink_result 1" spacing="0"/>
          <portSpacing port="sink_result 2" spacing="0"/>

  • Options
    Mark2121Mark2121 Member Posts: 7 Newbie
    It runs well! But the import function is not working. Do you have any idea, what the difference can be between two cvs loading?
  • Options
    Mark2121Mark2121 Member Posts: 7 Newbie
    Thank you for having helping me! Finally In solved the problem, as I assumed well, the problem was in the settings, I needed to reset two values to default value. I had misconfiged it earlier. In general settings the number of nominal values in meta data, and number of rows. I reseted them to 100, and now it works as It should

Sign In or Register to comment.