Problem Updating and Connecting to server Windows XP

BillB1007BillB1007 Member Posts: 3 Contributor I
edited November 2018 in Help
I have just discovered Rapid Miner 5.0 and have been amazed by the new look and the power of this tool.  Congratulations to Ralf and team.

I am now trying to update the Text Analysis plugin, but I am getting this error.

[tt]Message: Failed to access the WSDL at: http://rapidupdate.de:80/UpdateServer/UpdateServiceService?wsdl. It failed with: Connection timed out: connect.[/tt]

I just read a previous question with the solution for Windows 7.0 -- but I'm using Win XP Pro.  I tried right-mouse clicking and looking for an Administrator option but that wasn't available.

I wonder if this is a conflict with our corporate firewall or proxy server (I don't have problems downloading files from the web)? 

Thanks for whatever help you can provide.

Answers

  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,529   Unicorn
    Hi,
    if your company uses a proxy server for routing the access to the internet, you must define it for RapidMiner. The properties can be found in the system tab of the properties that can be found with Tools / Preferences. Please ask your system administrator for the settings. If this does not solve your problem, please ask again.

    And please excuse the long delay, we must have overlooked that topic somehow.

    Greetings,
    Sebastian
  • BillB1007BillB1007 Member Posts: 3 Contributor I
    Sebastian,

    Many thanks for your reply.  I'm very new to Rapid Miner 5.0 and I have not found the System tab.
    In the Tools/Preferences I see General, Gui, Init, Tools, Update.
    Is it listed in those options?

    Thanks again for your help.
    Bill
  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,529   Unicorn
    Hi Bill,
    sorry, but I wasn't aware that we have added this option after the last release. We will publish a new version tomorrow, after this it should work.
    If you urgently need the Text Processing Extension, I could send you a file by mail, that you would have to copy into the lib/plugins folder of RapidMiner's installation.

    Greetings,
    Sebastian
  • jeanlucjeanluc Member Posts: 18  Maven
    Sebastian Land wrote:

    Hi Bill,
    sorry, but I wasn't aware that we have added this option after the last release. We will publish a new version tomorrow, after this it should work.
    I tried to update a new installation of RM (build 5.0.001) at work as well where we have a proxy. Of course, it didn't work but I don't see the System tab either in the preferences. If this features is available after applying an update, this is not going to work since I cannot apply that update. Do you know when the proxy setup will be part of the main build?

    Thanks.
  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,529   Unicorn
    Hi,
    we have just today released the final version of RapidMiner. You might download the program on our website. Then the proxy settings should be available. If there are still any problems, please keep me informed.

    Greetings,
      Sebastian
  • jeanlucjeanluc Member Posts: 18  Maven
    I had forced the proxy on the old build with -DproxyHost=proxyhost -DproxyPort=8080 -DproxySet=true and it worked.

    There was a hiccup as at work I am behind a proxy that prevents .exe downloads so the auto-update failed. I downloaded the update via another ISP and reinstalled it.

    It would be nice if the auto-update packages are zipped first (even though the compression is not that big). I realize this is an issue that few people will encounter, though.
  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,529   Unicorn
    Hi,
    in fact the updates are zipped sets of files. We don't download any static files, these zip files are generated depending on the difference of your version and the target version.

    Greetings,
      Sebastian
  • BillB1007BillB1007 Member Posts: 3 Contributor I
    Hi Sebastian,

    I am still having a problem connecting with the Rapid-I server.  I have entered the proxy server address in the System tab, but that has not fixed it.
    I found some other posts from users who have had the same issue - some have found different ways to solve it ("starting in administrative mode"?).

    Are there any other ideas on what I can try? 

    It's not a major problem because it only affects plug-ins or automatic upgrades, but want to try to build up a user-base in our enterprise so people need to be comfortable with Rapid Miner before we can upgrade to the Enterprise edition -- hopefully that will happen.  When they see the RapidMiner News giving an error it will seem like a problem.
Sign In or Register to comment.