The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

rm gives error on my data, i tried to load it excell and csv format

yakaryosyakaryos Member Posts: 19 Contributor II
edited November 2018 in Help

hi

RM gives error....I load my data in several types, in excell and csv format. I read smilar topics in forum but I can't solve the problem. my data is below;

http://rapidshare.com/files/379941826/insan.xls.html

It has 13 attributes and 15671 examples, i tried a lot, but the problem is when i click finish on the loading page,it  close and repository don't include my data.

buy if i edit my data, i only use my 100 examples, there isn't a problem.

I am curious aboaut that rm is only for 100 examples?

what can i do?

best regards,

Answers

  • Options
    MartinKochMartinKoch Member Posts: 16 Contributor II
    Hi.

    I can give you two links to similiar problems:
    http://rapid-i.com/rapidforum/index.php/topic,1934.0.html
    and
    http://rapid-i.com/rapidforum/index.php/topic,1924.0.html

    They propably provide no solution but at least a workaround (which is from me actually).

    Hope it helps you.

    Nonetheless I'm curious about the real cause, too.

    Greetings,
    Martin
  • Options
    yakaryosyakaryos Member Posts: 19 Contributor II
    hi,
    i read all smilar topics in forum but i couldnt solve the problem. anyone can do it and explain for me?
    best regards.
  • Options
    landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Hi,
    I just tried to import your xls data to my repository and it worked without problems. So please make sure that,
    1) you entered a valid repository location in a reachable repository (file access must be possible)
    2) you have the newest version of RapidMiner.

    I must admit that I tested it with the current developer version. Might be that this problem has been solved since the last update.

    Greetings,
      Sebastian
  • Options
    yakaryosyakaryos Member Posts: 19 Contributor II
    hi,

    I think my problem will be solved when you make the last update. I am waiting for that. i have the last version of rp but the developer version is better than mine i think.

    best regards.
  • Options
    mcpretomcpreto Member Posts: 1 Contributor I
    I had a similar problem!

    The other forum threads didn't helped me. I had a very limited data set, so memory was not the issue. I'm using RM under Windows XP and the data loading failed without any error message.

    The problem was in my data set file format. I had an empty line at the end and a few lines ended with an empty cell.

    After editing my data file (it was a CSV file), the data loaded perfectly.

    I hope it helps you.

    Regards
    Marco Preto
Sign In or Register to comment.