🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

Attribute List Incorrect after Split

timdauriatimdauria Member Posts: 1 Contributor I
edited November 2018 in Help
After using the SPLIT node in RapidMiner, the attribute list in all subsequent nodes is incorrect - all the new split attributes are not names correctly and cannot be selected.  For example, if you place a SELECT ATTRIBUTES node after a SPLIT node (having selected unordered attributes in the split node), then select SUBSET in the SELECT ATTRIBUTES node, all the new split attributes will be incorrect.  I even tried using regular expressions to capture the new attributes without luck.  Does anyone have any suggestions?

Answers

  • MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869   Unicorn
    Hi timdauria,

    you've found a bug in the Split operator (that's how we call "nodes"  ;) ). However, it works correctly, and in the Select Attributes you can enter the attributes you want to filter by hand on top of the right list, even if they don't show up in the left list.

    Best regards,
    Marius
  • MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869   Unicorn
    One small addition for correctness: actually it is not really a bug, but since the output attributes of the split operator depend on the actual data (i.e. values of the examples) and not just on the meta data (i.e. attribute names and types etc.), it can't know which attributes it will output before it has actually been executed.

    Best,
    Marius
Sign In or Register to comment.