RapidMiner 9.7 is Now Available

Lots of amazing new improvements including true version control! Learn more about what's new here.


[SOLVED] Error launching RapidMiner from RapidAnalytics

BenDundeeBenDundee Member Posts: 3 Contributor I
edited November 2018 in Help
First, let me say, I found this thread, in which a very similar issue was posted. I tried the solution there, and found that it didn't work for me. This thread also has a similar issue on a different platform, but it's not clear to me that it's the same issue (please correct me, of course).

I'm trying to set up my work space with Rapid Analytics + Rapid Miner, accessing a MySQL database on Mac OSX 10.7. RapidMiner/Analyitcs versions are the current ones.

Also: java -version gives
java version "1.6.0_33"
Java(TM) SE Runtime Environment (build 1.6.0_33-b03-424-11M3720)
The launch fails at "Initializing XML Serialization", with the following info in the terminal:
14:15:04,860 INFO  [de.rapidanalytics.web.servlet.PluginServlet] Request: /resources.xml
14:15:04,862 WARNING [com.rapidminer] XML transformer does not support indentation: java.lang.IllegalArgumentException: Not supported: indent-number
The following details are provided by the launcher:

Under "Launch File":
<?xml version="1.0" encoding="UTF-8"?>
<jnlp spec="1.0+" codebase="http://localhost:8080/webstart/" href="http://localhost:8080/RAWS/rapidminer.jnlp">
<title>RapidMiner 5.2</title>
<icon href="rapidminer_icon.png" kind="default" />
<icon href="splashscreen_community.png" kind="splash" />
<shortcut online="true">
<desktop />
<menu submenu="Rapid-I" />
<offline-allowed />
<association mime-type="application-x/x-rapidminer"
extensions="rmp" />

<all-permissions />

<!-- Application Resources -->
<j2se version="1.6+" href="http://java.sun.com/products/autodl/j2se" initial-heap-size="1000m" max-heap-size="1000m"/>

       <jar href="rapidminer.jar" main="true"/>
       <jar href="launcher.jar" main="false"/>

       <!-- jar href="bcmail.jar" main="false"/ -->
       <!-- jar href="bcprov.jar" main="false"/ -->
       <jar href="SassyReader-0.5.jar" main="false"/>
       <jar href="blas.jar" main="false"/>
       <jar href="collections-generic.jar" main="false"/>
       <jar href="colt.jar" main="false"/>
       <jar href="commons-codec-1.4.jar" main="false"/>
       <jar href="commons-collections.jar" main="false"/>
       <jar href="commons-httpclient-3.1.jar" main="false"/>
       <jar href="commons-lang-2.4.jar" main="false"/>
       <jar href="commons-logging-1.1.jar" main="false"/>
       <jar href="concurrent.jar" main="false"/>
       <jar href="encog.jar" main="false"/>
       <jar href="freehep-export.jar" main="false"/>
       <jar href="freehep-graphics2d.jar" main="false"/>
       <jar href="freehep-graphicsio-emf.jar" main="false"/>
       <jar href="freehep-graphicsio.jar" main="false"/>
       <jar href="freehep-graphicsio-pdf.jar" main="false"/>
       <jar href="freehep-graphicsio-ps.jar" main="false"/>
       <jar href="freehep-graphicsio-svg.jar" main="false"/>
       <jar href="freehep-graphicsio-swf.jar" main="false"/>
       <jar href="freehep-io.jar" main="false"/>
       <jar href="freehep-swing.jar" main="false"/>
       <jar href="freehep-util.jar" main="false"/>
       <jar href="freehep-xml.jar" main="false"/>
       <!-- jar href="gentlyWEB.jar" main="false"/ -->
       <!-- jar href="glazedlists.jar" main="false"/ -->
       <jar href="groovy-all-1.7.7.jar" main="false"/>
       <jar href="ivy-2.2.0.jar" main="false"/>
       <jar href="jama.jar" main="false"/>
       <jar href="jcommon.jar" main="false"/>
       <!-- jar href="jdom.jar" main="false"/ -->
       <jar href="jep.jar" main="false"/>
       <jar href="jfreechart.jar" main="false"/>
       <!-- jar href="jh.jar" main="false"/ -->
       <jar href="jmathplot.jar" main="false"/>
       <jar href="joone-engine.jar" main="false"/>
       <jar href="jugpreview.jar" main="false"/>
       <jar href="jung-algorithms.jar" main="false"/>
       <jar href="jung-api.jar" main="false"/>
       <jar href="jung-graph-impl.jar" main="false"/>
       <jar href="jung-visualization.jar" main="false"/>
       <!-- jar href="jwnl.jar" main="false"/ -->
       <jar href="jxl.jar" main="false"/>
       <jar href="kdb.jar" main="false"/>
       <jar href="looks.jar" main="false"/>
       <jar href="mail.jar" main="false"/>
       <jar href="microba.jar" main="false"/>
       <!-- jar href="rome.jar" main="false"/ -->
       <jar href="rsyntaxtextarea.jar" main="false"/>
       <jar href="vldocking.jar" main="false"/>
       <jar href="ws-commons-util-1.0.2.jar" main="false"/>
       <jar href="xmlrpc-client-3.1.3.jar" main="false"/>
       <jar href="xmlrpc-common-3.1.3.jar" main="false"/>
       <jar href="xpp3.jar" main="false"/>
       <jar href="xstream.jar" main="false"/>
<property name="rapidminer.homerepository.url" value="http://localhost:8080" />
<property name="rapidminer.homerepository.user" value="bdundee" />

<application-desc name="RapidMiner 5.2"
main-class="com.rapidminer.gui.RapidMinerGUI" width="800" height="600">


<update check="background" />
It looks like (to my naive eye) that two exceptions are being thrown, possibly in some test that's run as an automated part of the startup. The error stack (?) is:
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.sun.javaws.Launcher.executeApplication(Launcher.java:1919)
at com.sun.javaws.Launcher.executeMainClass(Launcher.java:1852)
at com.sun.javaws.Launcher.doLaunchApp(Launcher.java:1614)
at com.sun.javaws.Launcher.run(Launcher.java:139)
at java.lang.Thread.run(Thread.java:680)
Caused by: java.lang.NoClassDefFoundError: junit/framework/Assert
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at com.sun.jnlp.JNLPClassLoader.findClass(JNLPClassLoader.java:345)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at com.rapidminer.RapidMiner.init(RapidMiner.java:551)
at com.rapidminer.gui.RapidMinerGUI.run(RapidMinerGUI.java:218)
at com.rapidminer.gui.RapidMinerGUI.launch(RapidMinerGUI.java:523)
at com.rapidminer.gui.RapidMinerGUI.main(RapidMinerGUI.java:505)
... 9 more
Caused by: java.lang.ClassNotFoundException: junit.framework.Assert
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at com.sun.jnlp.JNLPClassLoader.findClass(JNLPClassLoader.java:345)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
... 25 more


  • Nils_WoehlerNils_Woehler Member Posts: 463  Guru

    we recently changed our testing processes to improve the quality of our software. Ironically the webstart wasn't included in the testing process yet but it is now.
    Nevertheless due to these changes some JUnit classes are being imported when you start RapidMiner.
    Unfortunately these classes are missing on the RapidAnalytics server and in the jnpl file which leads to this error.
    This has been fixed but until we release a new version we recommend you to start RapidMiner from your local installation.

  • BenDundeeBenDundee Member Posts: 3 Contributor I
    Hi Nils:

    Thank you for your response. Is the time scale days, weeks, or months?

    I also suppose that this isn't an issue with the Enterprise Edition?

    Finally, I want to say thanks for a very compelling piece of software. I am have loads of fun with it :)
  • spoortispoorti Member Posts: 24 Contributor II
    Hello Nils,
    As per your comment the issue related to launching RapidMiner has been fixed in later releases,
    "This has been fixed but until we release a new version we recommend you to start RapidMiner from your local installation."
    I have installed RapidAnalytics using RapidAnalytics-CE-Installer-1.2.008.zip.
    When I launch RapidMiner from web interface of RA server, it directs me to java.sun.com website to install java which I already have on my m/c.
    Do I need to change anything to launch RM from RA server ?
    Also, what are the advantages of launching RM from RA server as opposed to launching RM locally ?
  • Nils_WoehlerNils_Woehler Member Posts: 463  Guru

    the fix for launching RapidMiner from RapidAnalytics hasn't been published yet.
    But it will be included in the 5.3 Release of RapidMiner that is planed to be released at the end of this month.

    If you have installed RapidMiner locally there is no advantage to start it from the RA server. But if you are in an enterprise environment where you sometimes do not have rights to
    install software this is can be useful.

Sign In or Register to comment.