XML error : invalid byte 1 of 1-byte utf-8 sequence

onkar-deshpandeonkar-deshpande Member Posts: 5 Contributor I
edited November 2018 in Help
Hello,

I am trying to convert JSON to XML and later on applying processes as per screenshot. But I am getting XML error while parsing. Can you please let me know what is missing from my end. Attaching screenshot of my process.

Not able to attach image.


Here is the sequence of processes -
Get page ---> JSON to XML ---> Remove Document Parts ---> Write Document ---> Read XML


Regards,
Onkar Deshpande
Tagged:

Answers

  • mschmitzmschmitz Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,225 RM Data Scientist
    Often this is caused by wrong encoding. Have you checked this?

    ~Martin
    - Head of Data Science Services at RapidMiner -
    Dortmund, Germany
  • onkar-deshpandeonkar-deshpande Member Posts: 5 Contributor I
    Hello,

    Thanks for reply. While converting JSON to Xml its not adding any encoding. Can you please tell me how to do that as I am getting response in JSON format.

    Regards,
    Onkar
  • mschmitzmschmitz Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,225 RM Data Scientist
    Write Document, Read XML and the Main process all have settings for the encoding. Especially if you get web pages you might want to set them to UTF-8.

    Have you checked the written XML for any flaws?

    ~Martin
    - Head of Data Science Services at RapidMiner -
    Dortmund, Germany
  • onkar-deshpandeonkar-deshpande Member Posts: 5 Contributor I
    Thanks for the reply. I was not setting any encoding standard while writing document due to which it was getting system default encoding standard. Now I have set the encoding standard to UTF-8 and its working.

    Thanks for your help.

    Regards,
    Onkar
Sign In or Register to comment.