ANNOUNCEMENT: RAPIDMINER 9.1 HAS JUST BEEN RELEASED!   PLEASE DOWNLOAD AND GIVE FEEDBACK. ENJOY AND HAPPY RAPIDMINING!   -- @sgenzer – Community Manager

how to: Read Database on Rapidminer Server

january_febrojanuary_febro Member Posts: 12 Contributor II
edited November 30 in Help

Hi, I created a process reads database and execute  and apply the gradient boosted tree model then append back the result to the database. If i run it locally it works fine. I save the process on the rapidminer server and when i run it causes  

  com.rapidminer.operator.UserError: Database Connection Failed. Please define connection properly (please see attached file for the process and error).

Now I tried to create a database connection in my rapidminer server inputting the proper data on the fileds, but it just gives me 

red box (Please see image file) if i will run using this setting it will give me a java nullpointer.

 

Thank you for your help.

Tagged:

Best Answer

  • Thomas_OttThomas_Ott Posts: 1,762   Unicorn
    Solution Accepted

    Can you try creating a new DB user (other than root) with a password and try it again?

Answers

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,762   Unicorn

    When you created the DB connection on Server, did you click test and get the green check mark?

     

    If it gives you an error, then there's something wrong with your connection parameters.

     

    You must give the DB connection on the Server and unique name "Server_DB" and then make sure to select that connection in your process to run it on the Server.

  • january_febrojanuary_febro Member Posts: 12 Contributor II

    Hi @Thomas_Ott

    Thank you for your reply. I followed your  instruction. The error did not display but it gives me red box (pls. see attached file).

    I think my settings is right:

    Name: Server_DB

    Database System: MYSQL

    Host: Localhost

    Port: 3306

    Schema: rapidminer_server (i created a table named es_sap)

    User: root

    Password: <empty>

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,762   Unicorn

    Did you add in your password?

  • january_febrojanuary_febro Member Posts: 12 Contributor II

    @Thomas_Ott 

    I did not put a password because in my localhost i also did not put password. Is the password required?

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,762   Unicorn

    So your root user has no password? I thought that's a must for the root user? No?

  • january_febrojanuary_febro Member Posts: 12 Contributor II

    @Thomas_Ott

    im using using xampp to for apache and mysql server. It's okay not to have a password for the root. 

    I also tried adding a new user:rmUser with password: pwsd but to no avail :(

     

    What should i do?:(

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,762   Unicorn

    Also check the Access Rights of the DB connection too, maybe your RM user doesn't have access rights to the DB connection you're creating.

  • january_febrojanuary_febro Member Posts: 12 Contributor II

    @Thomas_Ott  Thank you very much for your immediate response :smileyhappy:  

    I have successfully added a database  connection but when i run the process it  has an error  a database connection failed still, this time the proble is the unknown table. Im pretty sure i have that table :(

Sign In or Register to comment.